cancel
Showing results for 
Search instead for 
Did you mean: 

Report level filter, Require single selection not working

Hi All

 

I am facing the issue when we select/de-select "Require single selection" property for Page/Report level filter and save it in web service/Power BI desktop, it is again reverting these changes. I have started facing this issue from past 2 days.

Status: New
Comments
Moderator

Hi @daksh_arora1,

 

Does the issue occur for all reports? Please update the Power BI desktop to the latest version, make sure you have clicked Save to save the change. You can reopen the report to see if the change is disappear. 

 

In Power BI service, also make sure you have saved the change. After you refresh the report and in view mode, the "Require single selection" should be grayed and checked if you already select this option before saving the change. 

 

Best Regards,
Qiuyun Yu 

Frequent Visitor

 

Hi there,

 

I'm getting this issue now too - presenting in a very similar way to the original poster.

 

When you open the report, one of the report-level filters is set to Single Select. You can turn this off in PBI Desktop, but when you save the file and re-open it (or even if you refresh the data) that filter reverts to single-select.

 

It is only happening with one of our fields and on one of our reports.

 

We're on the November update of the Desktop client. We are using an SSAS data source in case that's relevant.

 

Any advice would be appreciated!

 

EDIT: Further wierdness. You can temporarily work around the issue by turning off single select and setting the filter to 'Advanced Filtering'. This doesn't appear to revert - but as soon as you turn it back to Basic Filtering, it reverts to Single Select again! So frustrating! Smiley Sad

Frequent Visitor

Hi,

 

I have additional information on this issue and can reproduce it. What is happening is, in PBI Desktop, it is possible to have different settings on a report level filter across pages. This SHOULD NOT be possible, because the filter is report-level!

 

Reproduce:

  1. Start with multi-page report.
  2. On one of the pages EXPAND the Filter pane
  3. Add a field to the report-level filters and select a value.
  4. If "require single selection" is unchecked, check it. If it is checked, uncheck it.
  5. HIDE the filter pane.
  6. Switch to a different report page. 
  7. EXPAND the filter pane and look at the 'require single select' option on the Report-level filter added in step 3.
  8. NOTE that the checkbox is still in its original state following step 3 and preceding step 4...i.e. it is DIFFERENT than on the first page.
  9. HIDE the filter pane and navigate back to the original page.
  10. EXPAND the filter pane--it is the same as you set in step 4! Again, this should not be possible because the filter is supposed to be report-wide.
  11. Now, WITHOUT hiding the filter pane, go to the second page again. Note that the 'require single selection' option does NOT change.

If you do steps 1-5 and then publish to the service or PBI Report Server, you'll find that whether you see the 'require single select' option checked (and, you can't change it from here) depends on which page you are on when you expand the Filter pane. Again, this is presumably not by design.

 

So the workaround is (in PBI Desktop):

  1. collapse filter pane
  2. Go to each page individually and repeat:
    1. Expand filter pane
    2. Configure report-level filter the way you want it
    3. HIDE filter pane
  3. Save & publish

I am sure this is not the intended process!