cancel
Showing results for 
Search instead for 
Did you mean: 

Report level filter NOT honored in Dashboard Q&A

Hello All.

I have a model that gets it data from a Power BI model in the same App Workspace. Let's call one the 'REPORT MODEL' and one the 'DATA MODEL'.

On the REPORT MODEL, there is a Report Level filter to remove one field's BLANK value.

 

2018-10-09_8-57-17.png   or: 2018-10-09_9-04-29.png

 

I create a single Dashboard from some charts from this model. 

 

When I enter a phrase in Q&A, the resulting chart OBVIOUSLY includes those (Blank) values. BUT, when I open the Visualizations and Filters pane to apply a filter to the chart that Q&A rendered, and try to apply the same filter here (removing Blanks), I don't see "(Blank)" as an option to exclude. 

 

2018-10-09_9-01-02.png

 

 

If Q&A is going to go back to the DATASET (the DATA model) to get it's data, then I should have the ability to filter out the Blanks. 

 

I can switch to ADVANCED FILTERING for this field and find the option that says, "is not blank", and that works, but in my opinion, if there is data that shows up with "(Blank)", then there needs to be that option in the Filters.

 

I see this as a BUG

 

COMMENT: NO, I cannot filter Blanks in the Power Query of the DATA model as this model will be used for other REPORT models that will need that data included. 

Status: New
Comments
Moderator

Hi @ToddChitt,

 

I'm not able to reproduce the issue on my side. The Q&A should create the visual based on the dataset data. As I tested, even though we set the filter on report to filter out blank value, we still need to set filter again for the visual generated from Q&A. 

 

q3.PNG

 

In your scenario, please check if the issue only happens to this report/dataset. Which data source does the dataset get data from? 

 

Best Regards,
Qiuyun Yu 

Member

@v-qiuyu-msft:

Thanks for your reply. It seems to NOT matter if I create the dashboard element from a chart in the DATA model or from a chart in the REPORT model. The result is the same:

 

The option of (Blank) does NOT show up as one of the available items to filter for that field. Why