cancel
Showing results for 
Search instead for 
Did you mean: 

Report canvas backgrounds changed when publishing report to service

For some reason some of my reports (published about 1,5-2 weeks ago) has suddenly a change in background color on the report canvas from the background color I have set in the PBIX to a dark grey + the background surrounding the report canvas has also gotten this dark grey color. It has also happened to some of the visualizations bakgrounds for one of the published  reports. 

 

I have not made any changes to the PBIX or in the service since publishing these files, so this seems to be a bug. 

 

bug2.pngBackground has changed for background surrounding canvas and for two viz on the report page

 

bug pbi service background1.pngGrey report canvas in PBI service

Status: Needs Info
Comments
Member
This idea would be really useful at this point.

https://ideas.powerbi.com/forums/265200-power-bi-ideas/suggestions/31311568-apply-theme-at-workspace...

I've also noticed that with themes in desktop, a specific setting for a visual overrides the theme, but that this is inconsistently implemented in the service. For example, on the service the text size for the title of an image appears at 12 pt, which is the theme setting instead of the specific setting for that visualization, which is 8 pt.
Regular Visitor

I'm glad to have clarity and a resolution.

 

"I am really unhappy with this change". I feel the same way, but the real issue is not that PBI "changed" but that the PBI documentation and execution of themes has been lacking. I'm still hopeful that one day this imrpoves, but there are things in the documentation that don't work in PBI and plenty of confusion generated by the PBI documentation itself.

Regular Visitor

So is there an easy way to change the default font and default font color for every visualization in the theme json without a ton of coding that doesn't change the default backgrounds?

Member

@ronrule et al,

 

Below is the basic pattern I used to set some standard font sizes/colors/etc.

 

I went through the pain of changing my theme, then applying my new theme to all my reports. It does not sound like this is something that is going to be "fixed" -- it sounds like instead, we have to change our themes.

 

(And I definitely voted for the idea of adding a way to quickly apply a new theme to many or all published reports, per the idea linked above!)

 

{
   "name": "..."
   ,"dataColors": [...]
   ,"background": "#FFFFFF"
   ,"foreground": "#000000"
   ,"tableAccent": "#000000"
   ,"visualStyles": {
      "*": {
         "*": {
            "*": [{
               "fontColor": {"solid": {"color": "#000000"}}
               ,"fontColorPrimary": {"solid": {"color": "#000000"}}
               ,"fontColorSecondary": {"solid": {"color": "#000000"}}
               ,"fontFamily": "Arial"
               ,"fontSize": 10
               ,"secFontFamily": "Arial"
               ,"secTitleFontFamily": "Arial"
               ,"titleFontFamily": "Arial"
            }]
            ,"categoryAxis": [{
               "fontSize": 13
               ,"labelColor": {"solid": {"color": "#000000"}}
            }]
            ,"columnHeaders": [{
               "fontSize": 11
            }]
            ,"legend": [{
               "labelColor": {"solid": {"color": "#000000"}}
            }]
            ,"valueAxis": [{
               "fontSize": 13
               ,"labelColor": {"solid": {"color": "#000000"}}
               ,"secFontSize": 13
               ,"secLabelColor": {"solid": {"color": "#000000"}}
            }]
         }
      }
   }
}
Frequent Visitor

 

Hello

I am confused with that new "feature"

I use the very basic JSON below, could someone please tell me what part should be changed to avoid the "black background" ?

 

Of course while maintening the current feature, that is to turn all the fonts' color to black by default.

 

Many thanks in advance Smiley Happy

 

{
  "name": "Police noire",
  "foreground": "#000000",
  "tableAccent": "#000000",
  "visualStyles": {
    "*": {
      "*": {
        "*": [
          {
            "fontSize": 9,
            "fontFamily": "Segoe UI",
            "color": {
              "solid": {
                "color": "#000000"
              }
            }
          }
        ]
      }
    }
  }
}

 

Frequent Visitor

This solved the "wallpaper" (which turned to black too) issue for me while maintaining the other customizations 

 

But this did NOT solve the page backround which is still black on the Service ....... 

 

Any help appreciated

 

 

{
  "name": "Police noire",
  "foreground": "#000000",
  "background":"#ffffff",
  "tableAccent": "#000000",
  "visualStyles": {
    "*": {
      "*": {
        "outspace":[{
          "color": {
            "solid": {
              "color": "#ffffff"
            }
          }
        }
      ],
        "*": [
          {
            "fontSize": 9,
            "fontFamily": "Segoe UI",
            "color": {
              "solid": {
                "color": "#000000"
              }
            }
          }
        ]
      }
    }
  }
}
Visitor

i tried adding the backgroung/foreground to the json file but that didnt do anything. 

 

Just like kevhav,  i had to remove the line  "color": {"solid": {"color": "#000000"}} under the VisualStyles section for the report to display correctly.  THANK YOU Kevhav.

 

Wish there was some type of "heads up" from microsoft when making these changes.  

 

Now to fix the remaining 8 reports... 

Member

Yes, we do have to fix our themes -- it is in preview after all Smiley Happy

What should be fixed however, is the WYSIWYG between desktop and the service. I don't like seeing surprises when I review a report and publish it and it looks different than the desktop. Or, when a report on the service changes, but I review the source PBID and it looks completely different from the service.

Regular Visitor

Another comment on this thread, I have no idea how it happened- But now some of my slicers text match the background color on selected.. This does not look very good, and I have not applied any settings in the theme on slicer visualizations. So no idea how that happened. Anyone has the same issue? Slicer.PNGSlicer visualization text match background color on selection