cancel
Showing results for 
Search instead for 
Did you mean: 

Rendered event firing prior to custom visuals rendering

I have built some automation that cycles through BPI report pages and screenshots them.  This was all working until around 3 days ago.  Now the screenshots were being captured prior to the page being fully rendered.  It seems as if all the standard visuals are fully rendered, but the custom visuals are not 100% completely rendered.  Did something change in PBI service and custom visuals where now the "rendered" event is firing prior to rendering of custom visuals?? Thanks!

 

Tony

 

Status: Needs Info
Comments
Community Support

Hi @tval,

 

Which custom visuals do you mean have issue? 

 

When you receive the email and go to the report on Power BI service immediately, do these custom visual display updated data? 

 

 

Best Regards,
Qiuyun Yu 

Community Support
Status changed to: Needs Info
 
Advocate I

Its this custom visual: https://okviz.com/card-with-states/

 

I have not tested with other custom visuals.  I'm not sure I understand your question about whether they display updated data.  If I go to app.powerbi.com and run the report, I notice nothing out of the ordinary.  The custom visuals start out with a spinning/loading icon and then fill in as expected.  Again, this all used to work until early last week and there was no changes on our side.  I added a five second delay as a workaround, but wanted to report the issue.

 

Tony

 

 

Community Support

Hi @tval,

 

I guess the "the custom visuals are not 100% completely rendered." means data not updated. If it's not, please share screenshots in Power BI service report and subscribe image. 

 

I have tested with the custom visual Card with states, the visual in subscribed email is the same as when we access it on Power BI service. How did you define the Card with states visual on your side? 

 

q3.PNG

 

Best Regards,
Qiuyun Yu 

Advocate I

I don't think you are following me.  I mean that the JavaScript API is firing the "rendered" event before the custom visuals are fully rendered.  See the documentation here.. https://github.com/Microsoft/PowerBI-JavaScript/wiki/Handling-Events

 

See screenshots below, one bad (not fully rendered) and one good.   The cards eventually fill in just fine, but the "rendered" event is firing too early.  This was not the behavior we saw before last week.

 

Bad, see blank cardsBad, see blank cardsGood, no blank cards (unless no data)Good, no blank cards (unless no data)

Anonymous
Not applicable

Hello,

Did you find any solution? Because at present that problem still occurs.

 

Thanks!

Advocate I

@Anonymous, no I never did find a solution.  I worked around the issue by just doing a long sleep instead of relying on the rendered event.  Not ideal, but ok in our use case.