cancel
Showing results for 
Search instead for 
Did you mean: 

RenderListDataAsStream Error when pulling from Sharepoint List Using Implementation 2.0

Since a few days ago, the sharepoint list I connect to is giving the following error:

 

 

 

DataSource.Error: Web.Contents failed to get contents from 'https://***hidden_for_security_reasons***/_api/Web/Lists(guid'99aadd91-ddc6-4295-866d-3d1ea6064fc7')/RenderListDataAsStream' (500): Internal Server Error
Details:
    DataSourceKind=SharePoint
    DataSourcePath=https://***hidden_for_security_reasons***
    Url=https://***hidden_for_security_reasons***/_api/Web/Lists(guid'99aadd91-ddc6-4295-866d-3d1ea6064fc7')/RenderListDataAsStream

 

 

 

I have seen a few other post on this topic but there does not seem to be an obivous solution

Status: Investigating

Whether consider publishing this report to Power BI Service and refreshing it to check the error refresh message to get more information about this issue.

 

Best Regards,
Community Support Team _ Yingjie Li

Comments
v-yingjl
Community Support
Status changed to: Investigating

Whether consider publishing this report to Power BI Service and refreshing it to check the error refresh message to get more information about this issue.

 

Best Regards,
Community Support Team _ Yingjie Li

MAHEswe
Frequent Visitor

I have the same error on an unchanged and published DataSet that has been running without issues the past year, until now.

 

The error message in PBI Services is similar:

Data source error: <pii> DataSource.Error: <pii>
Web.Contents failed to get contents from 'https://--------.sharepoint.com/sites/-------/_api/Web/Lists(guid'-------')/RenderListDataAsStream' (500):
Internal Server Error</pii>.
DataSourceKind = <pii>SharePoint</pii>.
DataSourcePath = <pii>https://---------.sharepoint.com/sites/------</pii>.
Url = -------(guid'-------')/RenderListDataAsStream</pii>. </pii>.
The exception was raised by the IDataReader interface.
Please review the error message and provider documentation for further information and corrective action.
Table: SupportTickets.

 

I use the Sharepoint Online list Connector 2.0 (Beta).

Tried with new PBIX from scratch and received same error before data preview FOR THIS LIST - but not for OTHER LISTS on same Sharepoint Online site.

This specific list that previously was "Support" now shows up as "Support [1]" (with an added [1] not there before), while all other lists looks like before.

 

It can't be excluded that changes have been made to the Sharepoint Online list-definition, but if so it must be possible to adjust this in Power Query.

When now choosing Transform data (despite that Preview could not be loaded) the selected Nabvigation ID seems right, but it still fails.

 

Since I for now don't know how to solve it I will need to remove that whole list from my DataModel, recreate the list in Sharepoint, move the data, loose item history, and reconnect to a new created list. There must be a better way, please advice.

 

MAHEswe
Frequent Visitor

Three days later update:

The Sharepoint Online list that suddenly crashed by Refreshes,

and showed up as "Support [1]" instead of "Support" when creating a new PBIX from scratch,

today three days later shows up as "Support" again, and do not crash the Refreshes.

 

I'm good for know, but it would be interesting to know the cause.

 

Can some Sharepoint Online List definition modification that usually shall work, has caused some temporary change in adresses, which after 1-3 days were back to as before?