cancel
Showing results for 
Search instead for 
Did you mean: 

Remove direct query table in PBI desktop

I've added a dataset to my model in PBI desktop for test reasons. Now I want to remove the table but there is no option to remove it (e.g. in the context menu as for all other tables). I then removed the dataset in PBI service to force PBI to let me remove the table. But this all doesn't work.
So, how do I remove the table from my model?

Status: New
Comments
v-lili6-msft
Community Support

hi  @fwde 

This is a preview function that directquery to power bi dataset, and have many limitations for now, you could have a look this document:

Deleting connections to remote sources that use DirectQuery is not currently supported.

 

https://docs.microsoft.com/zh-cn/power-bi/connect-data/desktop-directquery-datasets-azure-analysis-s...

 

and you could share your feedback and doubt about this

https://community.powerbi.com/t5/Desktop/Share-your-thoughts-on-DirectQuery-for-Power-BI-datasets-an...

 

 

 

Regards,

Lin

Andreas_B
Regular Visitor

Having the same issue now and I am wondering why not more users report it. 

 

Would have been nice to have a big warning also in the blog post or the moment you implement the connection. Usually trying a preview feature is not irreversible. Not understanding the reason for this limitation makes it a bit frustrating. 

MartinPBI
Helper I

Hi, 

Having the same issue here.  Tried this fonctionnality on a report I was working on, and now I am stuck with a connection to a Live Dataset thar I have no use for.  Basically it renders this dashboard unpublishable.

There should definitely be a big warning about this issue when advertising this functionality and a way to undo this should be shared asap by microsoft (even if it is a workaround, like editing json manually).

Seems like the "this is a not a bug, it's a feature" has turned into "it's not a bug, it's a limitation". 

Mainer04401
Helper III

Same problem here.  I was using mixed storage and one of the data sources that I was connected to through direct query was deleted and uploaded into a different workspace.  I tried to delete that direct query and I can't.  If I try 'change source', it imports new tables with (2) after them because it keeps the original tables.  

Martin_How
Frequent Visitor

Same issue here....no offence to no one, but some-one really dropped the ball on this one..

fwde
Advocate I

Hi @v-lili6-msft ,
Any news here? More and more people have the same problem. It's getting urgent!

MartinPBI
Helper I

I have not tested it but it seems corrected in february update

https://powerbi.microsoft.com/en-us/blog/power-bi-february-2021-feature-summary/#_Toc63074644

v-lili6-msft
Community Support

hi  all

you could get it in In yesterday's updated version.

Please upgrade to the latest version and try it.

 

Regards,

Lin

Patrick_Taggart
New Member

Hi @fwde  thanks for your detailed comments. I perfectly undertsand the issue you experienced earlier this year

 

Were you able to solve this with the later versions of PBI desktop? We are having the exact same problems. Once the direct Query PBI dataset is in my dekstop model I cannot delete it at all 

 

I am on the May 2021 version 

 

Kind regards, 

 

Patrick

fwde
Advocate I

Hi @Patrick_Taggart,
Yes, from the February 2021 version on it works. You have to delete the connection in the Data source settings.

Here you find an instuction:
Remove direct query table in PBI desktop - Page 2 - Microsoft Power BI Community
Kind regards,
Frank