cancel
Showing results for 
Search instead for 
Did you mean: 

Refresh schedule failures

Recently we are continously facing this issue:

Failure details: The last refresh attempt failed because of an internal service error. This is usually a transient issue. If you try again later and still see this message, contact support.

 

{"error":{"code":"DM_GWPipeline_Gateway_TimeoutError","pbi.error":{"code":"DM_GWPipeline_Gateway_TimeoutError","parameters":{},"details":[],"exceptionCulprit":1}}}

 

I have changed timeout time in data gateway config file and reduced the data load but they all do not work.

 

Anyone has suggestions, please?

 

 

Status: New
Comments
New Member

Same Issue

Frequent Visitor

Same here, issues started Saturday 28th March.  

 

 

error proc data.png

Frequent Visitor

OK, I now see that we probably have different issues - as the other users here seem to have a timeout issue, maybe caused by high pressure on PBI Service due to Covid making many people work from home...

 

But I will share my solution anyway, as it may help someone:

 

In some cases Dataset Refresh fails, and it can be solved by removing the dataset and republish it. Today I did a deep dive with good help from PowerBI Support (Avinash) which showed that the problem was due to a Dashboard Cache that held links to my Dataset that somehow got broken.
We tried to delete the Dahboard Tiles that were linked, then republished the dataset fron PBI Desktop, to the same workspace and the same name (overwriting it). This solved the issue and the Dataset could again refresh as normal.
I need to rebuild my Dashboard Tile (and one dashboard) which is a bit painful, so i suggest a way to manually, in the PBI Service, delete the Dashboard Cache, so that this does not prevent Dataset Refresh.

Frequent Visitor

I need more information to be able to help you. Are you refreshing datasets or dataflow? If you click on details on refresh failure you can copy the information to this post?

New Member

same issue for me

Frequent Visitor

Please post more details in order to help you. Some weeks ago Microsoft had the problem with Date Type Fields. Change them to Text and see if the Problem still occurs. (Of course this is not the final solution) but in order to understand if you have the same Problem i faced.

Regular Visitor

I am facing the same issue, In a Direct Query published report on a Premium workspace, tried updating the datasource and then the credentials using the PBI APIs (the API calls shows Success), but then when i go to view the report in the workspace it shows error.

 

Capture.PNG

It refreshes and connects with the update datasource when I download the updated pbix file and open it in local. 

However, if I follow the same steps, pulishing in a normal workspace, the report refreshes perfectly with the updated datasource data.

 

(Note: Datasource is a cloud storage)
Any help will be highly appreciated, Thanks.

Frequent Visitor

Please click on show technical Details and post the message in order to help you.

New Member

Removing the dataset (consequently, the report too) solved the problem for me. 

New Member

I am facing the following issue when I am trying to update the credentials for Azure Blob storage in Power BI service.

I have used the same access key in the desktop version and it works fine. Somehow cannot update the key to schedule refresh in Power BI service.

Failed to update data source credentials: The credentials provided for the AzureBlobs source are invalid. (Source at https://texdlstoraccglobalprod.blob.core.windows.net/.)