Showing results for 
Search instead for 
Did you mean: 

Refresh error The credentials provided for the SharePoint source are invalid

Dataset cannot be refreshed.

The problem is with the SharePoint credentials. Credentials have not been changed.


Data source status is successful.


I tried to change the authentication method and the privacy level and I got the same error.

Also, refresh is successful in PowerBI desktop but after republishing in the service error appears.

Log in to the SharePoint site directly is working.


Does anyone have the same problem? Any ideas?

Thank you.

Status: New
Community Support

hi @lale24 


Try clearing the cache and re enter your credentials, make sure your password is not expired.

and you could also create a support ticket for assistance if necessary.




Advocate I

Hi @v-lili6-msft 


Password is not expired. I tried your suggestion but still, I'm having the same error.

Is there something else I can try?


A support ticket is created today.


Thank you.