cancel
Showing results for 
Search instead for 
Did you mean: 

Refresh Fails with Microsoft SQL Error

This has been happening to me on and off for the last couple months:

 

When I try to refresh a report in the desktop, I sometimes receive this error, and once I receive it on a particular file it continues to happen over and over again. In this particular case, I am connecting to an Azure instance and attempting to refresh tables and views.

 

"Microsoft SQL: A connection was successfully established with the server, but then an error occurred during the login process. (provider: SSL Provider, error: 0 - The certificate chain was issued by an authority that is not trusted.)"

 

I've resolved this in two different ways:

1. Options and Settings -> Data Source Settings -> clear permissions or clear global permissions and provide credentials again.

2. After trying every clear permissions route I could think of, I published to a workspace, and then I tried refreshing on the desktop and it worked!

 

However, I'm encountering this problem again and neither of these past solutions works. I can go into another pbix file and do the same refresh and it works. It seems something becomes corrupted in the file??? Microsoft, is this a bug? Lots of postings about it on the Internet with lots of different solutions. I'm unable to find the solution that works for me.

 

Is anyone else running into this? Has anyone else found a solution?

Status: Needs Info
Comments
Moderator

@Shelley,

Do you connect to Azure SQL database in Power BI Desktop? What version of Power BI Desktop do you use? Do you use any certificate?

Regards,
Lydia

Moderator
Status changed to: Needs Info
 
Member

Yes, in Power BI Desktop. I am on the latest version, December. I don't know about any certificate. Everything normally worked fine, and then this started sporadically happening in the last few weeks - maybe since the December release? In fact, just this morning, I opened an existing pbix file, and pulled in a new table just fine. I am now trying to add another table and it sits "Waiting for xxx.cloudapp.net" - so now I either receive that error or it hangs up waiting and waiting and will never pull in the file. Yesterday it sat spinning for an hour as I tried to refresh. Oh, after 5-10 minutes now, the one I was trying to pull in just started pulling records. What the heck is going on here? This is impacting my productivity. 

Moderator

@Shelley ,


Do you get any issues when using SQL Server Management Studio(SSMS) to connect to the Azure SQL database? And are you able to refresh the table in SSMS?

In addition, please update to Feb release 2019 Power BI Desktop(2.66.5376.1681) and check if the issue goes away.

Regards,
Lydia