cancel
Showing results for 
Search instead for 
Did you mean: 

Records with the latest date in dataset falling off the disply

Please forgive the newbie; hoping for a SIMPLE explanation...  I am having 'sudden' issues with my dashboard.  It seems that no matter what dataset I bring in, the displays are suddenly dropping the latest date.  For example, if the dataset contains data out to 5/3/2037, every records before this date is displayed, but having this date is being dropped.  This is consistent regardless of when the last date is, or how many records have this date...  they're all being dropped.  I was able further prove this out by simply adding a record with a date one month later, that was, as expected, dropped, while the one previously being dropped, was now included1.  Of course my first thought was the Page and/or Report filters (no Visual filters set), but for one thing, those do not have date parameters, only if not blank, which they're not.  The missing record(s) are included in the data query behind each page/pbix, just not displayed on the screen...  And it seems this JUST started happening after an update I did to my desktop (Version: 2.49.4831.521 64-bit (August, 2017)).  Is there some kind of built-in EOF I'm not aware of?  Perhaps having just a < and not <= ??  not too sure...  Another clue, when I publish the pbix (one taking a few mins to refresh) the correct amount is displayed while its refreshing, then is removed after that... (please see attached photo)  Many thanks in advance for any guidance or assistance on solving this!       

    

 

2017-08-22 14_29_31-FW_ Dashboard issue - Message (HTML).png

 

Status: Needs Info
Comments
Super Contributor

@jsimon

 

Do you have the custom visual TimeLine slicer in your report? If yes, there is a known issue mentioned in this thread: timeline slicer missing today when all dates selected

 

Best Regards,
Herbert

Established Member
Status changed to: Needs Info
 
Frequent Visitor

hmmm... thanks for mentioning the issue connected to the slicer...  Prior to updating to the PBI version that triggered this data issue, the slicer visual itself was being displayed 'blank' on each page, with a message stating that "there are too many dates to include...".  The new update saw the return of values in the visual, but loss of any records having the very last date -only.  Now that I have rolled back the version, the visual is once again blank, but at least [all] the data is once again being reported; it definately seems that somehow this 'updated' visual is dropping off values when no specific range is being identified...  For now Im just going to work with older version...

Thanks again!

 

 

 2017-08-24 10_11_40-1002 - Power BI Desktop.png

      2017-08-24 10_45_12-PE Dashboard.png