cancel
Showing results for 
Search instead for 
Did you mean: 

RLS NOT supported for Featured Tables in Excel’s Data Types gallery

Featured Tables in Excel’s Data Types gallery doesn't work when I create one (or more) role(s) in power BI desktop for RLS. I leave the Table filter DAX expresion blank in power BI desktop, so I should have access to all rows. It just doesn't work in spite of the power BI team mentioning:

RLS is now supported for Featured Tables in Excel’s Data Types gallery

We’ve continued to improve the featured tables capability with row-level security support. Now, when you mark a table as featured and then publish to the Power BI service, that table will appear in Excel’s data types gallery even if it has RLS rules applied. Previously, these tables were not shown in Excel. This new enhancement means that users in Excel will only see the rows of data they have access to.

Power BI Desktop June 2020 Feature Summary | Microsoft Power BI Blog | Microsoft Power BI

 

Yes, I do see the featured table in Excel, but it recognizes none of my selected Excel cells when the power BI report has Roles (RLS). The moment I remove the role in the power BI desktop file and republish everything works as expected.
I can't deactivate RLS obviously, so I'm stuck not being able to implement this featured tables on my most important data set 😞

@SujataNarayana , it would be great if you could confirm this issue. Even greater would be to put a fix on the roadmap.
Kind regards

Status: New
Comments
v-chuncz-msft
Community Support

@sebadb9 

 

I can reproduce the issue and will keep you posted with any updates.

CRI 235851186

v-chuncz-msft
Community Support

@sebadb9 

 

We’ve identified the issue and this will be fixed in May.

sebadb9
Advocate I

Absolutely brilliant @v-chuncz-msft !
Thank you for following this up. I'll let you know sometime in May if I can make it work! 👍👍😁

sebadb9
Advocate I

Hello @v-chuncz-msft I just tested this on my existing dataset, but it stil doesn't work. Do I need to republish the pbix or refresh something? Maybe the fix hasn't been deployed yet? Where can I follow the status of CRI 235851186?

Thank you