cancel
Showing results for 
Search instead for 
Did you mean: 

RLS Error on Live SSAS cube without RLS

A few weeks ago, some accounts started receiving errors when viewing reports. These accounts could access reports without issue in the past. It only appears to affect some accounts, which is especially strange. 

 

Error: The report can't be viewed because the underlying dataset uses row-level security (RLS). 

RyanAck_0-1611095428459.png

 

Here is the report setup: 

  • P1 Premium assigned to the origin workspace 
  • Report built of multidimensional SSAS cube using a live connection
  • On-prem gateway is being used, and appears to be functioning without issue 

Here's the kicker: there is NO row-level-security in this report, nor in the SSAS cube! RLS does not exist anywhere close to this report.

 

I am stumped, we've had a case open with Microsoft but no resolution yet. If we come to one, I will update this post. 

 

Has anyone else run into this?

 

 

Status: New
Comments
Community Support

@RyanAck 

 

Thanks for your update. We understand that the issue may be urgent and you have created a support ticket. Hopefully, it could be resolved soon and it would be great if you could share the solution to help more users.

Helper I

@v-chuncz-msft yes absolutely!

Helper I

@v-chuncz-msft no solution discovered as of yet, though the problem is getting worse and affecting more users. I started receiving this error myself on a report, I believe this is a bug within the Power BI service.  

Helper I

@v-chuncz-msft this issue turned out to be a bug within the Power BI gateway version (Nov 2020). We updated the gateway version and the problem went away.