cancel
Showing results for 
Search instead for 
Did you mean: 

R visual error - dplyr package version issue

One of my R visuals have stopped working and I get the the following error on the service. The visual is working fine on Power BI desktop. 

 

The package version of "dplyr" that I have on my desktop is 0.7.6. The version on the service is 0.7.4. I tried searching for this error and it seems it has to be do with the version and upgrading the version should fix it. 

 

Power BI - R packages

 

Script Runtime Error



Attaching package: 'dplyr'



The following objects are masked from 'package:stats':



    filter, lag



The following objects are masked from 'package:base':



    intersect, setdiff, setequal, union



Error in filter_impl(.data, quo) : 

  Evaluation error: `as_dictionary()` is defunct as of rlang 0.3.0.

Please use `as_data_pronoun()` instead.


Please try again later or contact support. If you contact support, please provide these details.
Activity ID: 577b0e4d-5880-4a04-83b0-2a41f5f58ed6
Request ID: b8e8bd0e-c967-7d28-802f-d76118ba25ef
Correlation ID: 1b3bdc86-25e0-a7ce-99c2-910b5f910fe4
Time: Tue Aug 13 2019 10:03:46 GMT+0100 (British Summer Time)
Version: 13.0.10388.151
Cluster URI: https://wabi-north-europe-redirect.analysis.windows.net
Status: New
Comments
Regular Visitor

I have the same issue. For now, I've modifed my visual to not use the tidyverse library and that seems to have fixed it. 

Anonymous
Not applicable

I have the same issue with plotly. looking for solution now

Regular Visitor

I do have same issue .  R visual was working fine in Power BI service and now all sudden stopped working with the following script error message:

"Error in arrange_impl(.data, dots) : Evaluation error: `as_dictionary()` is defunct as of rlang 0.3.0. Please use `as_data_pronoun()` instead.  
Please try again later or contact support. If you contact support, please provide these details.

Activity IDcbda9843-4767-4f56-a52b-118d1d1d1533
Request IDba1f329a-1c0f-0148-6c1c-173c123b1af4
Correlation IDfab7d10b-b5a5-b031-38a3-c823672865b1
TimeWed Aug 14 2019 00:07:24 GMT+0530 (India Standard Time)
Version13.0.10388.179
 
I have tried to update dplyr and rlang but no luck. Visual works fine on Desktop.
Here is the R studio session dump:

> sessionInfo()
R version 3.5.3 (2019-03-11)
Platform: x86_64-w64-mingw32/x64 (64-bit)
Running under: Windows >= 8 x64 (build 9200)

Matrix products: default

locale:
[1] LC_COLLATE=English_United States.1252 LC_CTYPE=English_United States.1252
[3] LC_MONETARY=English_United States.1252 LC_NUMERIC=C
[5] LC_TIME=English_United States.1252

attached base packages:
[1] grid stats graphics grDevices utils datasets methods base

other attached packages:
[1] plotly_4.9.0 ggplot2_3.2.1 dplyr_0.8.3 htmlwidgets_1.3 XML_3.98-1.20

loaded via a namespace (and not attached):
[1] Rcpp_1.0.2 pillar_1.4.2 compiler_3.5.3 later_0.8.0 tools_3.5.3
[6] digest_0.6.20 jsonlite_1.6 tibble_2.1.3 gtable_0.3.0 viridisLite_0.3.0
[11] pkgconfig_2.0.2 rlang_0.4.0 shiny_1.3.2 rstudioapi_0.10 crosstalk_1.0.0
[16] yaml_2.2.0 withr_2.1.2 httr_1.4.1 tidyselect_0.2.5 glue_1.3.1
[21] data.table_1.12.2 R6_2.4.0 purrr_0.3.2 tidyr_0.8.3 magrittr_1.5

[26] scales_1.0.0 promises_1.0.1 htmltools_0.3.6 assertthat_0.2.1 xtable_1.8-4
[31] mime_0.7 colorspace_1.4-1 httpuv_1.5.1 lazyeval_0.2.2 munsell_0.5.0
[36] crayon_1.3.4
>

Any pointer?

 

 
Anonymous
Not applicable

same here

Regular Visitor

+1. Looking for help

Community Support

Hi all, 

 

Please share a pbix file which contains some dummy data with us to reproduce the issue. You can upload the pbix file to your OneDrive and paste the share link here. 

 

Best Regards,
Qiuyun Yu

Regular Visitor

Microsoft: Same problem as other posts.  Please update.  We have no control over the versioning of R packages.  (I was exicted to use R within Power BI: please don't make me go external to perform real analytics.)

 

Thanks, Mike

Regular Visitor

same here

Regular Visitor

Hi @v-qiuyu-msft 

 

Here's the link:

 https://kaltire-my.sharepoint.com/:f:/p/taleen_chen/EoRRvK8HI7BIo0LEI8itwsgBU2NDAXxM0eIlc-7EmwBGdA?e...

 

If you are unable to open these files, please let me know.

Thank you for your help. I look forward to your response.

 

Best regards,

Taleen 

Regular Visitor

Same issue over here with a feature from ggpubr library.  More specifically, the below command is working on Desktop but not on service. Tried to install all libaries  according to power bi version list but it did not help either. Please note that I don't get any error.   

+ stat_compare_means(label = "p.signif",ref.group = ".all."

 

Thank you,

George