cancel
Showing results for 
Search instead for 
Did you mean: 

R visual error - dplyr package version issue

One of my R visuals have stopped working and I get the the following error on the service. The visual is working fine on Power BI desktop. 

 

The package version of "dplyr" that I have on my desktop is 0.7.6. The version on the service is 0.7.4. I tried searching for this error and it seems it has to be do with the version and upgrading the version should fix it. 

 

Power BI - R packages

 

Script Runtime Error



Attaching package: 'dplyr'



The following objects are masked from 'package:stats':



    filter, lag



The following objects are masked from 'package:base':



    intersect, setdiff, setequal, union



Error in filter_impl(.data, quo) : 

  Evaluation error: `as_dictionary()` is defunct as of rlang 0.3.0.

Please use `as_data_pronoun()` instead.


Please try again later or contact support. If you contact support, please provide these details.
Activity ID: 577b0e4d-5880-4a04-83b0-2a41f5f58ed6
Request ID: b8e8bd0e-c967-7d28-802f-d76118ba25ef
Correlation ID: 1b3bdc86-25e0-a7ce-99c2-910b5f910fe4
Time: Tue Aug 13 2019 10:03:46 GMT+0100 (British Summer Time)
Version: 13.0.10388.151
Cluster URI: https://wabi-north-europe-redirect.analysis.windows.net
Status: New
Comments
Community Support

Hi @taleenilat

 

Thank you for your detail information. I tested with your pbix file but not able to reproduce the issue in Power BI service on my side. Please test again on your side. 

 

@all Please test again on your side to see if the issue still occurs. 

 

Best Regards,
Qiuyun Yu

Regular Visitor

In my case the issue persists.  (ggpubr librabry)

Regular Visitor

It appears, as of this morning, that the issue has been resolved on our end. 

 

Thank you.

Regular Visitor

Hi @v-qiuyu-msft , the issue is resolved. Thank you.