cancel
Showing results for 
Search instead for 
Did you mean: 

R Powered Custom Visual not rendering properly on Power BI Service

I have managed to get everything working as expected with a custom visual that i have built. Except 1 thing. It works absolutely fine when the plot is vertical. 

I am using the coord_flip() function to rotate my plot to be horizontal.  

The coord_flip() function rotates my plot but the bars seems to be really weird. 
 
This is my only issue atm. Please give me so workaround/fix. 
 
I urgently need to send this report out.
 
FYI, the visual works perfect when used on PBI Desktop. The problem occurs when I publish the file to Power BI service.

 

coord_flipissue.png

Status: New
Comments
Moderator

Hi @rmohanty008

 

Do you use R visuals in Power BI desktop then run the R script to lot the visual? If it is, please refer to this document to check if the packages in your script are supported in Power BI service: https://docs.microsoft.com/en-us/power-bi/service-r-packages-support

 

Best Regards,
Qiuyun Yu 

 

 

Frequent Visitor

Hi Quiyun

I have pckaged the R visual as a pbiviz and then uploaded it as a custom visual into my PBI desktop file. It works fine on the PBI desktop. But as shown in the image, the rendering gets messed up on the service because of the coord_flip() function. 

 

I am guessing this is a bug in the service. 

 

Is there any workaround for this?

Moderator

Hi @rmohanty008

 

As it's a custom visual instead using R visual, I would suggest you post a new thread in this forum to get help: https://community.powerbi.com/t5/Custom-Visuals-Development/bd-p/CustomVisualsDevelopmentDiscussion

 

Best Regards,
Qiuyun Yu