Showing results for 
Search instead for 
Did you mean: 

Publishing from Desktop to Service is Not Working

I have tried publishing a report three times now and it sits and spins and spins. It never appears to finish nor does it give an error. I am on the July release and this just started this morning. Earlier this morning I published this same report successfully, but ever since about 8:30 AM Central time, I can no longer publish. In fact it is sitting right now, at about 15 minutes and is still spinning. I need to get these revisions published. Is anyone else having this same issue?


Status: Needs Info

Hi @Shelley,


The latest Power BI desktop version is August 2.61.5192.601, please update your Power BI desktop to this version then test again. 


Also you can open Power BI service, click Get Data -> Files to publish the report to see if the same issue occurs. 


Best Regards,
Qiuyun Yu 

Status changed to: Needs Info

I updated to the August version and still the same issues.


Then, after 8:00-8:30 AM Central time today, I was able to publish again.


I guess I'll wait to see how it is the rest of today and then again on Monday.


I'm having this issue again. I waited more than 16 minutes for a report to publish. It just keeps spinning and spinning. I walked away for another 15 minutes or so and then came back to an error that I do not have permission to publish to the workspace. This is really frustrating. I've wasted over an hour on this and it still will not publish. I've tried both methods above and when trying to publish from the service I cannot tell if it even did anything or what's going on with it. I now tried from inside the desktop, going to the menu and clicking publish, rather than simply pushing the publish button. It is going on four minutes and still spinning. I tried logging out and back in again and I also tried shutting my machine down and starting over and still no dice. Any ideas? Is anyone else having these same issues?