Showing results for 
Search instead for 
Did you mean: 

Problems with native connection Google Big Query



I have a problems with a connection between PowerBI and Google Big Query. 


After validate my credentials, I recived the message:


"ERROR [HY000] [Microsoft][DriverSupport] (1120) SSL verification failed because the server host name specified for the connection does not match the "CN" entry in the "Subject" field or any of the "DNS Name" entries of the "Subject Alternative Name" field in the server certificate."

What I can do?


Status: New
Community Support

@Anonymous ,


As the error message mentioned, you may input incorrect host name. Please check if the credentials you have input is correct.



Jimmy Tao

New Member

Actually I am facing the same problem. The input credentials are correct, since they are the same ones that I use to log into bigquery directly.

Regular Visitor

exact same issue, tried two different BigQuery accounts and both failed the same way.


There is no way (that I can see) to edit the OOTB PowerBI Google BigQuery connection .

Frequent Visitor

I am having the same error. Are there any solutions to this?

Regular Visitor

same issue. The hostname is correct (or at least cannot be controlled by the user) as it is using the out of the box connector that Power BI provides natively. That connector only asks for you to sign into your google account - which I can do so successfully - but the error gets thrown when it tries to surface the objects that the user has access to. My user has GCP admin access and can create and destroy BigQuery tables so would think I would be able to consume from them as well. 

Regular Visitor

Found a work-around (solution) for my error in PBI desktop connecting to BigQuery... Disclaimer: this is deactivating corporate-enabled software, so proceed at your own risk.


Solution steps:

- Exit Zscaler (from system tray icon > right-click icon > Exit Zscaler)

- Reattempt the PBI::BigQuery and it works no problem


Permanent fix: I requested IT to update zscaler to whitelist this connection... for an officially supported solution.


zscaler icon>