cancel
Showing results for 
Search instead for 
Did you mean: 

Problem with usage metric report showing users who have not used the report before

I am using the default usage metric report. It shows a few users who have opened the report 100+ number of times for a specific time period. These report opens seem to be for a specific day i.e. 26th march user x opened the report 100+ times.

For report page views it is showing blank. When reaching out to these users, they have actually informed they have not opened the report before!

 

Why else could there user ID appear showing they have used the report when they have not?

Status: New
Comments
v-lili6-msft
Community Support

hi

I check some of my reports, all the usage metric report work well.

try to refresh the dataset or delete the existing Usage Metrics Report dataset, Then you can run View Usage Metrics again to generate a new dataset with its associated improved usage metrics reports.

https://docs.microsoft.com/en-us/power-bi/collaborate-share/service-modern-usage-metrics

 

if still have the problem, please check power bi audit logs to track user activities in Power BI:

https://docs.microsoft.com/en-us/power-bi/admin/service-admin-auditing

 

Regards,

Lin

yk1984
New Member

Hello Lin,

 

I have done both, deleted the report and generated a new one and also refreshed the usage report multiple times but still shows certain users who have viewed the report hundreds of times when they have never opened the report before. This is very strange, never really faced this issue with these usage reports in the past, this is the first time...

v-lili6-msft
Community Support

hi

This is very strange, and I could reproduce this problem.

I would suggest you create a support ticket to get further help from power bi support team.

 

 

Regards,

Lin