cancel
Showing results for 
Search instead for 
Did you mean: 

Problem with Google data sources connection

Hello! I have a big problem with data sources connection in PBI Desktop, especially WEB page from Google Spreadsheets.

Today I come across with this problem with my existing data, I have been working for a year with these sheets and everything was OK:

“The URL may be wrong or you might not have provided the right credentials to the server.”

As usual I Publish to the web my online Google sheet) and then I get new Web data to PBI Desktop and nothing =(..I have an empty window. PBI displays:

"We didn’t find any tables on this web page. No items selected for preview."

http://prntscr.com/vlgucs 

http://prntscr.com/vlguos

Please let me know how to overcome this issue.

Status: New
Comments
Regular Visitor

Same problem! Espero pueda resolverse pronto.

 

Saludos

New Member

Same problem over here.

 

Awaiting some feedbacks.

Regular Visitor

Same problem. 
Any news ?

Regular Visitor

Hola, una disculpa por responder en español .

 

Veía un hilo de otro usuario que comentó haber encontrado una solución provisional (https://community.powerbi.com/t5/Issues/DataSource-Error-The-downloaded-data-is-HTML-which-isn-t-the...). La solución es cambiar el nivel de privacidad a la fuente de datos a "Cualquiera que tenga el enlace". Solo así se actualiza y se lee correctamente la información. No obstante me preocupa mucho dicha "solución provisional", por que al cambiar el nivel de privacidad de nuestros datos, el nivel de seguridad es mucho menor.

 

Quisiera saber si ¿Alguno de ustedes ha tenido la oportunidad de contactar a soporte técnico?

 

Saludos

Regular Visitor

Same problem.

I hope, the solution will be found soon.

Frequent Visitor

Same problem. 

 

Regular Visitor

We are having the same problem here. 

I hope they solve this soon

Regular Visitor

Copying over my post from another thread (https://community.powerbi.com/t5/Issues/DataSource-Error-The-downloaded-data-is-HTML-which-isn-t-the...

 

The fix by changing the privacy level to "anyone with link" in Google Sheets is a problem for users with clients that have a concern re: data privacy and thus, is not a long term solution. 

 

I found that if you Embed instead of Link when Publishing to Web and then use the URL in between the code below you can connect to the Excel table in PowerBI. 

 

<iframe src="URL"></iframe>

 

The one issue with this approach is that there are slight differences between the way the table imports (e.g., empty rows in row 1 and 3) which cause a little rework in Query Editor. Fine if you have one workbook; however, a pain if you have many workbooks and data sources. Also, whose to say this won't also be affected by a change one day...

New Member

First solution, in the share button activate the option "anyone who has this link" and that's it.

 

Solution for those who do not have the option to leave the link open as public or do not wish to do so

 

""https://docs.google.com/spreadsheets/d/{your ID}/export?format=xlsx&id={your ID}""

 

In the link above, replace by the ID of your document that is, "{your ID}" by your "ID"

change the resulting link to the one you currently have in BI and voila.

 

Note.- your ID is in the URL of the sheet, it is the one between "https://docs.google.com/spreadsheets/d/ " and "/ view # gid = 64684168867"

Advocate II

Hello David!
Thank you for the new idea! 

Unfortunately, it doesn't work for me (I mean ""https://docs.google.com/spreadsheets/d/{your ID}/export?format=xlsx&id={your ID}""). 😔

Has anybody else tried it? What were your results?🤔