cancel
Showing results for 
Search instead for 
Did you mean: 

Problem with 2nd January 2018 update - can't apply query changes

Yesterday I installed the latest PBI Desktop update for January 2018 - the second one for January.

 

Now, when I Edit Queries and create a new table, then try to apply those changes, the "Apply Query Changes" step gets stuck on the "Creating connection in model" step. It never finishes.

 

I have reverted to the earlier (12th Jan) version and it works fine. 

 

Has anyone else seen this?

Status: Needs Info
Comments
Power BI Team

We've just released a new February update on the Download Center and Windows Store where this issue should be fixed.

 

Alex Gorev.

Regular Visitor

Thanks Alex Gorev ... good to see that the problem has been recognised.

 

Well, it's a step closer to working .... which is good. But still not working correctly.

 

I downloaded that new February release. Went into Query Editor, made a duplicate of one of my simple queries which loads a 20 row table. All looked good in Query Editor.

 

Hit Close & Apply. This time it completed the 'Creating connections in model' step, but then it didn't load any data. The table was empty. I did a Refresh Data on the table and it was populated correctly.

 

I repeated the process one more time just to be sure, and the same thing happened - Close & Apply did not load data to the new table.

 

 

Frequent Visitor

Hi all,

 

I am facing the same issue. For me, after clicking on "Apply now", few records are getting loaded and after that, it's just never-ending. I was running this in feb version and now I reinstalled the 2017 december version. I have the same issue.

My data source is API and the data are generated by web scrapping. It all looks good in the Query editor. 

 

Please suggest something, what needs to be done.

 

Thanks

Frequent Visitor

Seems to have worked for me. Now, when I select blank query from UI in Query Editor my blank query appears without much delay, and when I Enter Data and apply changes the data loads in my data model. This is using the old file that previusly was failing.

 

 

By no means a comprehensive test, but looks fixed.

Advisor

I'm still hitting this issue with the 9 Feb 2018 build 2.55.5010.621.

 

"Refresh" on a single table or the entire model or "Apply Query Changes" step gets stuck on the "Creating connection in model" step. It never finishes. It either crashes or you have to crash the PBI Desktop windows app. Data source of one query is small Excel file 18kb - reading ~70 rows, ~10 columns from 1 sheet. Same result on other machines trying to run the same model with the 9 Feb 2018 build of PBI Desktop.

 

Reinstalled build 2.54.4970.761 (7 Jan 2018 build) and suddenly it works as expected. The single query refresh is done in a few seconds.

 

Please put more effort into regression testing and bug fixes - we are wasting so much time installing, uninstalling and testing, which is work that Microsoft should be doing once to get it right for all of us. Rant ends.

Moderator

Hey Mike, sorry to hear you're still hitting this. Can you send us the PBIX file? We haven't been able to reproduce this so we'd appreciate your help. You can PM it to me if you don't want to send it publicly. 

 

Thanks!

Will

Regular Visitor

Has anyone moved forward with this issue?

 

I have just tried the "new latest" February version of Desktop (2.55.5010.641). My version of the problem still exists.

When I go to Query Editor, duplicate a very simple table of 20 rows (whose data source is an XLS). Then hit Close & Apply - it no longer gets stuck in the "Creating connections in model" loop, but it DOES NOT load any data to the table. When I look at the data in the tables in the model, the original table has its 20 rows; the new table has no data (unless I go and manually update it).

 

I have tried this with 2 different data models - same result.

 

 

Advisor

@WillT - I sent you a PM about this recently - I'd really like to share the PBIT file with you and get this resolved.

 

I'm still seeing this same issue with the 13 Feb 2018 build - 2.55.5010.641.

Regular Visitor

I have just installed the March 2018 PBI Desktop update.

The problem STILL PERSISTS!

 

Just for the record, the problem is still as follows ... I go to Query Editor on an existing model; create a duplicate of a small table; hit Close and Apply; I get the "Creating connection in model" step; but it DOES NOT PROGRESS to the "Loading data" step.

If I subsequently click on the new table and Refresh Data, it loads fine.

BUT that's not how it's supposed to work, is it?

 

Is anyone from Microsoft looking into this at all??  The problem has now existed since beginning of January!

 

 

Frequent Visitor

I got the same problem, too annoying