cancel
Showing results for 
Search instead for 
Did you mean: 

PowerBi Query containing native query not refreshing on Excel for MacOS

Hello,

 

We have Excel spreadsheet with PowerBI query calling a data source type of SQL Server when run on MacOS now gives are uses the following error:  The evaluation was canceled because it contained a native database query for the data source with kind SQL.  See screen capture below.  Some other Excel / PowerBI queries work fine on Mac but we cannot see the difference in the code with one that works vs. not working.  The one working does not show up the native query warning.

 

All of these reports/queries run perfectly in Excel for Windows.  we have made sure "Require user approval for new database queries" is un-checked. Same issue.  Currently, have a ticket open with Microsoft too with no luck yet.

 

According to users, these native query reports did work then suddenly stopped working.  Not sure if that's true or not.

 

Any thoughts or advice/ suggestions would be amazing.

 

Thank you.

 

cwpickens_0-1657133647838.png

 

Status: Investigating

Hi @cwpickens ,

 

We see that you mentioned that a support ticket has been opened and the engineers will do their best to resolve your issue. I can't reproduce your issue at this time, but we will discuss it with other colleagues and gather feedback to see if there is any feedback from other users with similar experiences to yours.

 

Best Regards,
Community Support Team _ Caitlyn

Comments
v-caitlyn-mstf
Community Support
Status changed to: Investigating

Hi @cwpickens ,

 

We see that you mentioned that a support ticket has been opened and the engineers will do their best to resolve your issue. I can't reproduce your issue at this time, but we will discuss it with other colleagues and gather feedback to see if there is any feedback from other users with similar experiences to yours.

 

Best Regards,
Community Support Team _ Caitlyn

cwpickens
New Member

Just sending an update. 

 

We may have found one commonality.  Appears reports with connection type OLD DB query fresh on Mac and queries with data model not refreshing. 

 

I am waiting for the customer to send me another copy of a report to test with and will confirm

 

Working.png

 

 

 

Not Working.png  

 

 

cwpickens
New Member

Ok, sending an update.  Confirmed.  I had customer remove the "“Add this data to the data model" and the query re-freshing on MacOS.   Any suggestions for this incident please?

 

 

cwpickens_0-1657318622951.png