cancel
Showing results for 
Search instead for 
Did you mean: 
0

PowerBI > Xero Connection - Unable to reset or reapply credentials

Since mid-February, we have been unable to update/refresh the data for this data source.

 

Logic dictated that removing access and reapplying (in case credentials needed refreshing) was the correct course of action however errors and reconnection issues occur.

 

Underlying error message: [DataSource.Error] Web.Contents failed to get contents from 'https://identity.xero.com/connect/token' (400): Bad Request
Cluster URI: WABI-AUSTRALIA-EAST-A-PRIMARY-redirect.analysis.windows.net
Activity ID: 112a3b02-7bb6-4c43-b77b-bc6523335ebc
Request ID: 979d6b41-a465-95ce-03c2-3031465ad985
Time: 2022-03-08 05:22:16Z

 

InsightPerth_0-1646717392219.png

 

 

InsightPerth_1-1646717409401.png

 

Does anyone have any insight as to how to correct this issue? We have also manually removed the 'Connected App' ie. PowerBI from within Xero to see if this would enable the reconnection to proceed however it had no affect.

 

If anyone has any ideas to try, it would be greatly appreciated.

 

Thanks all!

Status: Delivered

Hi @Insight-Perth ,

 

Currently, this app is not listed in Microsoft AppSource and it is also removed from the official document. That should be the cause of this issue.

 

Here is a similar issue related to Xero template app.

Solved: Did the Xero App get deleted? - Microsoft Power BI Community

 

Best Regards,

Community Support Team _ Caiyun

Comments
v-cazheng-msft
Community Support
Status changed to: Delivered

Hi @Insight-Perth ,

 

Currently, this app is not listed in Microsoft AppSource and it is also removed from the official document. That should be the cause of this issue.

 

Here is a similar issue related to Xero template app.

Solved: Did the Xero App get deleted? - Microsoft Power BI Community

 

Best Regards,

Community Support Team _ Caiyun