Showing results for 
Search instead for 
Did you mean: 

PowerBI dataset fail on scheduled refresh

Hello everyone,

I'm using Microsoft 365 usage analytics app from PowerBI apps store. I have configured report by oficial Microsoft guide:


Initial connection and data loading occurs successfully with OAuth autentication type.
When I schedule daily refresh, it is failing during refresh with following error:


Last refresh failed: Thu Oct 08 2020 11:16:03 GMT+0300 (Eastern European Summer Time)
There was an error when processing the data in the dataset.Hide details
Data source error: {"error":{"code":"ModelRefresh_ShortMessage_ProcessingError","pbi.error":{"code":"ModelRefresh_ShortMessage_ProcessingError","parameters":{},"details":[{"code":"Message","detail":{"type":1,"value":"The credentials provided for the OData source are invalid. (Source at<TENANT_GUID>/UserActivity.)"}}],"exceptionCulprit":1}}} Table: UserActivity.
Cluster URI:
Activity ID: 1080b5cf-1617-4df9-a6f3-4c0df7ce4651
Request ID: 8bc90250-6ea3-4cb8-9c21-335bcac58e98
Time: 2020-10-08 08:16:03Z


If I retype credentials under dataset and manually refresh, connection and data loading happens successfully.


I'm pulling out data from another Office 365 tenant using credentials with Global Reader Role.
In Office 365 tenant with PowerBI i'm Global Administrator.


I'm not using PBI Gateway.

Status: New
Community Support

hi  @AigarsJ 

Go to Dataset Settings, specify a valid credential for the data source, then refresh the dataset again. 

"You have to be either a Global adminExchange adminSkype for Business adminSharePoint adminGlobal reader or Report reader in order to establish the connection to the template app. See About admin roles for more information."



and do you mean when you retype data source credential then it could refresh successfully, it sounds power bi "forgets credentials" after you refresh it manually? please try to clear browser cache and try it again.





Regular Visitor

As I said i'm Global Reader.

Cache clear doesn't help, same issue when using in-private mode.

I have also tried to schedule automatic refresh (without any manual refresh after) - refresh fail with same error message - "The credentials provided for the OData source are invalid."