cancel
Showing results for 
Search instead for 
Did you mean: 

PowerBI: Unable to connect with SQL database with Sept Update - Error during Pre-login handshake

I am all of a sudden getting an error on all of my reports connected to an external db using Windows creds. to login.   This just started occuring 2 days ago and we have yet to resolve.   

 

Error reads: 

Microsoft SQL: A connection was successfully established with the server, but then an error occurred during the pre-login handshake. (provider: HTTP Provider, error: 0 - )

 

Any Help would be so greatly appreciated. 

Status: New
Comments
Regular Visitor

here you can find previous versions

https://docs.microsoft.com/en-us/power-bi/fundamentals/desktop-latest-update-archive

 

 

In pbi options there's a checkbox to disable update notification.

I've read somewhere that maybe you can disable it while installing using the following flags (have yet to test it):

PBIDesktopSetup_x64.exe -quiet -norestart ACCEPT_EULA=1 DISABLE_UPDATE_NOTIFICATION=1

 

 

New Member

This is also affecting multiple users in our environment.  Version: 2.85.681.0 64-bit (September 2020) is installed and SQL connections were working just fine before installing this update.

Frequent Visitor

@Supp I don't see how rolling back Power BI Desktop will solve the problem with the On-Prem Data Gateway. Can you elaborate?

Regular Visitor

@JBartlettHV  I was referring to PBI Desktop answering rigelng1995 on how to get older versions

 

But now that you mention it, maybe same can apply to the on-prem gateway: did you try previous build at ?

https://docs.microsoft.com/en-us/data-integration/gateway/service-gateway-monthly-updates

 

We didn't update the gateway (it's still at july update) so we don't have that problem for now

New Member

We have faced this error in our company when try to connect to Sql sever whith windows authentication login after update to Sept version.with downgrade to August version we handle this issue.

 

Microsoft

For the folks who hit the isue, which version of SQL server is hitting the issue?

New Member

@GN-MS Our user is not having any issues accessing SQL Server 2016 DBs. 

 

We've confirmed with our vendor that they are running SQL Server 2012 and this is where we are seeing the error.

The user is able to connect to the SQL DB using SSMS, but is getting the error when trying to connect to or update reports that are on the SQL Server 2012.

Advocate IV

SQL Server 2012 (11.0.3156) here. Again, my experience so far is that it seems to be isolated to datasets using Incremental Refresh.

Microsoft

From the investigation so far, the issue appears to be caused by a change in the version of the SQL provider that is used by the Sept gateway version.

 

There are two work arounds possible:

1. rollback to the ealier version of the gateway.

2. https://github.com/dotnet/SqlClient/issues/609 explains a solution based on the SQL server.

 

We will release patched version of the gateway rolling back to previous versions of SQL provider.

New Member

@GN-MS Will the Power BI Desktop application also receive an update that rolls back to the previous versions of SQL provider?  Luckily we didn't update our Gateway, but our existing Power BI Report writers can't modify existing reports that are connecting to the 2012 DB, nor can they create new reports with data from these DBs.