cancel
Showing results for 
Search instead for 
Did you mean: 
0

PowerBI Service: PDF/Powerpoint with not export Current Values.

When attempting to export to Powerpoint/PDF with Current Values  , pdf/PP with default values is exported

Status: Delivered

Hi @carlol ,

 

Thanks for the waiting! Product group has confirmed it is a bug with export to pdf, and they have created a tracking bug to fix it. Currently, they haven't provided expected available time of the fix. Once they provide this kind of info, I will post here. Thanks for your understanding!

 

Best Regards,

Community Support Team _ Caiyun

 

Comments
v-cazheng-msft
Community Support
Status changed to: Investigating

Hi @carlol ,

When exporting the report to PDF/PPT with current values, it exports the report in the current state, which includes the active changes we made to slicer and filter values. And URL filters aren't currently respected when choosing "Current Values" for your export. For more details, you may refer to Export reports to PDF - Power BI | Microsoft Docs.

In addition, may I know whether there is any custom visuals in your report? Is this issue taking place in all your reports or just one specific report?

Also, there is a similar issue may help you.

Solved: Export to PDF from Service not respecting Current ... - Microsoft Power BI Community

 

Best Regards,

Community Support Team _ Caiyun

carlol
Helper III

Hi 

 

I did test these in PowerBI Service and PowerBI desktop ; they where working.

 

  • PowerBI Desktop -- still working 
  • PowerBI Service -- Intermittent

 

Microsoft released a fix on  22nd of November 2019 for this

 

Scenario

 

Six Reports published via an App in PowerBI Service

 

I have Created a Slicer Pop Out Window with Bookmark Buttons in Power BI

I click on the button , it unhides a slicer ; users makes selection , report reflects filter selection, User can close the Slicer (Hide)

 

No Custom Visuals

 

PowerBi Service

Action: I make a change to the slicer , export to PDF using Current Values

Outcome: 

I can replicate three scenarios 

  1. Default Values are still illustrated even though Current values where selected
  2. First Page reflects the Current Values but the proceeding pages reflect the default values
  3. Reports with one page only, export correctly with Current values 

 

 

 

 

v-cazheng-msft
Community Support

Hi @carlol ,

 

Thanks for your reply! I basically understand it and will try to repro it. But if it is convenient for you, could you please provide a link of download sample pbix file and let me know the version of your Power BI service so it will be easier for me to investigate on this issue? Tanks in advance!

 

The way of checking the version of Power BI service: Help&Support>About Power BI>Service version

vcazhengmsft_0-1649228104715.png

 

Best Regards,

Community Support Team _ Caiyun

carlol
Helper III


Service version 13.0.17993.49

 

Pm you the link to pbix file location

v-cazheng-msft
Community Support

Hi @carlol ,

 

Have received the sample pbix file. Thanks you very much!

 

Best Regards,

Community Support Team _ Caiyun

v-cazheng-msft
Community Support
Status changed to: Accepted

Hi @carlol ,

 

Issue has been reported internally(ICM 302132184). Will sync here once there is any update.

 

Best Regards,

Community Support Team _ Caiyun

v-cazheng-msft
Community Support
Status changed to: Delivered

Hi @carlol ,

 

Thanks for the waiting! Product group has confirmed it is a bug with export to pdf, and they have created a tracking bug to fix it. Currently, they haven't provided expected available time of the fix. Once they provide this kind of info, I will post here. Thanks for your understanding!

 

Best Regards,

Community Support Team _ Caiyun

 

carlol
Helper III

Thanks Caiyun 

 

Keep me posted on progress

carlol
Helper III

Any update, still not fixed ?

C4YNelis
Advocate II

@v-cazheng-msft ,

 

This bug is defininately still around. We also experience this bug now. No matter what I select, refresh, etc., export to PDF is only possible with default values.

 

What's more, before it worked just fine while developing the report in June / July. I've trained the company on using the report and all was good. I've since gone on holiday for three weeks, just came back, installed the August version (of both the gateway and PBI Desktop), haven't changed a single thing about the report itself and now we cannot export to PDF anymore while keeping the current value?

 

This unfortunately defeats the whole purpose of my report, which has cost me quite some time to develop!

 

Can anyone at least please confirm this bug is still being fixed?

 

Cheers,

Niels