cancel
Showing results for 
Search instead for 
Did you mean: 

Power Query Editor Bug: Cannot Enable Load of Query

I have 4 queries in my Power Query editor.

I disabled load for a few of them by right-clicking the query name.

 

Now I changed my mind and want to turn it back on, but it will not allow me. I try to right-click and choose "Enable Load" from the menu, but then it warns me that disabling it will break my visuals. I am not trying to disable it, I'm trying to re-enable it.

 

I found a workaround: If I duplicate the query, the new one that appears is also disabled but I can enable that one.

 

It seems like there is a bug here.

Status: New
Comments
Community Support

@CmdrKeene ,

 

I could not reproduce this issue. The power bi desktop version on my side is 2.78.5740.861 64-bit (February 2020). Please make sure power bi desktop is the latest version.

 

Regards,

Jimmy Tao

Helper III

I installed the February update before I encountered this. My about box shows version string of 2.78.5740.841 64-bit (February 2020).

 

It looks like even after a reboot it's still happening. Maybe it's related to the type of data connection it is (it's an Excel file right now but it's really a proof of concept and another one will be made that connects to SQL soon).

But yeah, the query name is in an italic font and if I right-click and choose to enable, it prompts me asking if it should disable it (but it's already disabled, I was the one that disabled it originally).

 

It's not blocking my work because for now I was able to workaround it, but I'm not sure how it got into this state.

 

screenshot.png

Frequent Visitor

Hi,

 

Have you found a fix for this issue. I'm getting the same problem.

Helper III

Unfortunately not, although it wasn't too terrible to just duplicate the query and enable the new one/delete the old one.

Regular Visitor

Hi,  I also had the same problem with version 2.78.5740.981 64-bit (February 2020). Duplicating the query, enabling the new one and deleting the old one as CmdrKeene suggested solved the issue.

 

Also I am not sure how I got into that state, and I have been trying but unfortunately can`t reproduce the issue.

Regular Visitor

I have 2.78.5740.861 64-bit (February 2020), and it's just done exactly the same to me as you describe.  I turned off Enable Load on a query and now I cannot turn it back on again.

 

Thanks for the tip on referencing - that has worked for me.