cancel
Showing results for 
Search instead for 
Did you mean: 

Power Bi Embedded edit mode text box bug

it happened this morning. We are not able to edit the text box anymore in the power bi embedded application under edit mode.

Status: Investigating

Hi @ejQap 

Based on the above information, if you are a Power BI Pro licensee, you can create a support ticket for free and a dedicated Microsoft engineer will come to solve the problem for you.

It would be great if you continue to share in this issue to help others with similar problems after you know the root cause or solution.

The link of Power BI Support: https://powerbi.microsoft.com/en-us/support/

For how to create a support ticket, please refer to https://community.powerbi.com/t5/Community-Blog/How-to-create-a-support-ticket-in-Power-BI/ba-p/6830...

 

Best Regards,
Community Support Team _ Ailsa Tao

Comments
orygreg2
Frequent Visitor

We are seeing same/similar issue.  The main problem is the text boxes appear as blank for those users we've given read/write access to the reports.  For example, we have the Report Title in a text box.  It appears blank for "Read/Write" users.  But for "Read-Only" users, the text appears fine.  For the same report - if we view it in the powerbi.com service, the text appears fine - whether we're in read-only mode (the default) or if we switch to Edit-mode.  Problem seems to be restricted to Embedded reports.

 

Ailsa-msft
Community Support
Status changed to: Needs Info

Hi @ejQap 

So it's normal in Power BI Service ,right ? As @orygreg2 said , for "Read-Only" users, the text appears fine. It only appears blank for "Read/Write" users , are you having the same problem now ? Have you tried to remove and re-add the text box in the report, and then re-embed the report?

 

Best Regards,
Community Support Team _ Ailsa Tao

g2a-consulting
Regular Visitor

Hi @Ailsa-msft,

I would like to backup @ejQap demand, as we are getting a similar issue too. Problem exists only on Power BI Embedded, on Service and Desktop it works fine.

Text box seems "greyed out", typing text into oblivion, changing font style or font size doesn't work either.

textbox-bug.png

 

 

Embed configuration "permissions" is set to "All" and "viewMode" to "Edit", so it should work fine.

It has been working with current configuration for several months, but not anymore for text box edition.

let embedConfiguration = {
    type: 'report',
    id: xxx,
    settings: {
        panes: {
            filters: {
                visible: true,
                expanded: true
            }
        }
    },
    embedUrl: xxx,
    accessToken: xxx,
    permissions: 7, // All,
    tokenType: models.TokenType.Embed,
    viewMode: 1 // Edit
};

 

ejQap
Regular Visitor

@Ailsa-msft same problem with @orygreg2 and @g2a-consulting.

 

It happened only in Power BI Embedded for "Read/Writer" users. Otherwise, working great

anewsom
Regular Visitor

We are having the same issue, Read/Write all text boxes are blank, Read Only is fine.

izzat
Regular Visitor

Same behavior as mentioned. Just blank when in edit mode.

View mode is fine

 

Tested another text box visual. same result

Currently just making card and measure as workaround

Ailsa-msft
Community Support
Status changed to: Investigating

Hi @ejQap 

Based on the above information, if you are a Power BI Pro licensee, you can create a support ticket for free and a dedicated Microsoft engineer will come to solve the problem for you.

It would be great if you continue to share in this issue to help others with similar problems after you know the root cause or solution.

The link of Power BI Support: https://powerbi.microsoft.com/en-us/support/

For how to create a support ticket, please refer to https://community.powerbi.com/t5/Community-Blog/How-to-create-a-support-ticket-in-Power-BI/ba-p/6830...

 

Best Regards,
Community Support Team _ Ailsa Tao