cancel
Showing results for 
Search instead for 
Did you mean: 

Power BI reports taking ages to publish and getting frequent "contact the owner of this workspace"

Since this morning we are having massive difficulty publishing reports to our workspaces. There are a number of reports, both with live data sources or "presentation" ones based on static spreadsheets over various workspaces. Regardless of the data source or complexity of the models they are taking anywhere between 30 minutes to an hour or more to publish if they publish at all. We have also frequently been receiving an error saying we cannot publish to a workspace please contact the admin/owner (that would be me!) I've check and the workspace login matches my PBI login. Also logged out of both and back in again to make sure it wasn't that, also, my colleague is having the same problems and has done the same thing. The reports we're working on were the same that, yesterday, were publishing in a few minutes (let's say 3 minutes max for the most complex). I spoke to our IT guys and they haven't made any changes or noticed anything out of the ordinary and the changes we've made are little more than cosmetic so should not result in such a sharp increase in upload time. Please could you let us know if there is anything else we can do from our end to identify the cause?

Status: Needs Info
Comments
Anonymous
Not applicable

Same issue for us (premium customer too). Can't believe this isn't being flagged on the Power BI support page


tomkvarby
Frequent Visitor

Same problems for me today.

wjeanes
Advocate II

@Anonymous @SSF_GB @Anonymous @Anonymous @Anonymous @tomkvarby 

 

I'm not sure if this helps, but we recently I noticed that our Gateway (we use the personal version for now as we're a small team and it's easier to manage) was still the Nov-18 version and updated it which was around about the time we started having issues.

 

I'm going to try rolling back to the previous version and will let you know if that makes a difference.

 

That being said, the publishing problem seems to have corrected itself for us but our automatic refreshes through the Gateway are failing fairly regularly due to timeout issues that we never had before.  However it is very rarely the same report or reports that share a dataset so the problem doesn't appear to be realted to that.

SSF_GB
Frequent Visitor

I'm still on Nov 18 Gateway, so it's not that...

DanP
Advocate I

Same for us. Dashboard broken in service but still working on desktop, tried to re-publish to see if it fixes issue but just hangs.

SSF_GB
Frequent Visitor

https://powerbi.microsoft.com/en-us/support/   - status page showing no issues, which is clearly completely rubbish.

 

Too many people reporting issues with the service for there not to be some major fault. (Dare I say, a critical issue)

Anonymous
Not applicable

I'm sure Microsoft are pretty selective about what they show on the support page!

neilmanson60
Frequent Visitor

Same issues for us - we cannot publish, get strange errors including no permissions or just spins indefinitely, have raised a support ticket but no feedback from Microsoft. 

dom99
Advocate IV

Same problem here, we are a Premium customer too and its been flakey for the last week but today especially we cant publish o release anything.

 

The support page "Everything is running smoothly" .... I take this status with a bucket of salt

lattys
Frequent Visitor

Same issue here (Hungary). 

I can't publish, refresh (scheduled or on-demand) plus I can't create usage metrics as well.

PBI_Issue.PNG

 

At least they wrote it in the support page now.

I hope it could resolve ASAP.