cancel
Showing results for 
Search instead for 
Did you mean: 

Power BI reports taking ages to publish and getting frequent "contact the owner of this workspace"

Since this morning we are having massive difficulty publishing reports to our workspaces. There are a number of reports, both with live data sources or "presentation" ones based on static spreadsheets over various workspaces. Regardless of the data source or complexity of the models they are taking anywhere between 30 minutes to an hour or more to publish if they publish at all. We have also frequently been receiving an error saying we cannot publish to a workspace please contact the admin/owner (that would be me!) I've check and the workspace login matches my PBI login. Also logged out of both and back in again to make sure it wasn't that, also, my colleague is having the same problems and has done the same thing. The reports we're working on were the same that, yesterday, were publishing in a few minutes (let's say 3 minutes max for the most complex). I spoke to our IT guys and they haven't made any changes or noticed anything out of the ordinary and the changes we've made are little more than cosmetic so should not result in such a sharp increase in upload time. Please could you let us know if there is anything else we can do from our end to identify the cause?

Status: Needs Info
Comments
Visitor

I have the same problem in Italy.

 

I hope that Microsoft fix it as soon as possible!

Visitor

We got the same issues. At least the second day with this challenge this year. Today it has been impossible to upload new reports to the PowerBI.com service

Visitor

@v-yuezhe-msft 

New strangness happening.

 

Some (not all) titles are being set as "Off" when publishing.  They are still visible in the source PBIX being published.  When comparing the original (source) PBIX and a downloaded version, they are identical and all titiles are visible.

 

In addition some of my colleagues are having issues accessing published reports which they are trying to present to prospective new clients.  Really not ideal.

 

PBIConnection issues.png

 

 

Frequent Visitor

The same Issue here - cannot publish. Stops after taking a looong time with either telling me,

  • I don not have the rights to publish to this workspace
  • or terminates with a 404 error

Pls see srshot below.

I am talking about a report with 1,7MB filesize!

 

Pls MS-Team fix this asaperror_Publishing404.jpgerror_WorkspacePublishingRights.jpg

Thanks for acting fast & professionally!

Visitor

I've just submitted a support ticket and included the link to this feed so hopefully that might move things along.

Visitor

Same problem for me. Trying to publish a report but it just hangs. Usually this was taking 1-2 minutes. I understand issues like this might appear (not good as we are paying a lot of money for a reliable reporting tool) but at least MS should inform about this and let us know that they are working on it...

Frequent Visitor

We have observed some other weird behaviour - when we are trying to assign row level security on a dataset in the workspace it doesn't populate any of the users/groups from Azure AD so we cannot assign any groups into Roles. Suspect a related issue but shall raise a separate ticket.

Moderator

@wjeanes @neilmanson60 @sliti @alexrobe @arnehelgesen ,

Do you still get the above issue? A same issue has been reported internally : CRI 111036973. Will post back once I get any updates.

Regards,
Lydia

Visitor

@v-yuezhe-msft 

 

The issue is still occurring intermittently, some days are fine but others like today are terrible.  We have updated PBI desktop to the March version but it hasn't made much difference.

 

We found a "fix" for the disappearing title problem, which basically entails switching of every title on every table, visual, etc and the switching them back on again before publishing.  This is a massive hassle when you gave a 9 tab report with on average 5 - 10 visual elements per tab.

Visitor

@v-yuezhe-msft @wjeanes 

 

I'm having a similar issue to @wjeanes, PBI Desktop works and sometimes it lets me publish but other times it won't and will keep throwing back errors. 

 

I've been getting the "can't load visual" error as well, have added screenshots too... 

 

Thanks dashboard error.jpgload visual.jpgrefresh data.jpg