cancel
Showing results for 
Search instead for 
Did you mean: 

Power BI not connecting to SSAS Multidimensional model correctly.

I create a report in PBI desktop that reads from an SSAS cube.  When I publish the report and go to the PBI site to validate that publish worked OK, I get a "couldn't access the data source error."  My gateway is working for all data sources EXCEPT SSAS and I am the Admin, so the error message refers back to me to fix it.  This used to work with previous gateway versions.  

Status: New
Comments
Community Support

Hi @BrianMillerHF

 

Please go to Manage Gateways, ensure the connection of SSAS data source is successful, configure Map User role if necessary. Then go to Dataset Settings, ensure the dataset uses the proper on-premises data gateway. For more details, see: https://docs.microsoft.com/en-us/power-bi/service-gateway-enterprise-manage-ssas

 

Best Regards,
Qiuyun Yu

New Member

Connection to SSAS source is successful and the dataset is configured to use the gateway.  I still get the error message.  I am the Admin of both environments so I would expect that the admin of PBI nad PBI gateway should be able to access a cube I built (and can access with SSMS).

Community Support

Hi @BrianMillerHF

 

Have you checked your Power BI account in Azure Active Directory (Azure AD) match the UPN in your our local Active Directory instance? See: https://docs.microsoft.com/en-us/power-bi/service-gateway-enterprise-manage-ssas#map-user-names-for-...

 

Best Regards,
Qiuyun Yu