cancel
Showing results for 
Search instead for 
Did you mean: 

Power BI - Unable to execute a stored procedure or SQL Statement with SQL Server with backslash

Hi Team,

 

Greetings !!

 

I’m facing an issue while connecting Power BI with SQL Server as source. When I tried to execute a stored procedure / SQL Statement, Power BI took me to the page of authentication. Though I tried with Windows  / Database credentials, Unable to establish SQL Server connection. I found  that Power BI is not able to handle the server name with “\”. (eg., SQL-Dev\SQL123).

Status: New
Comments
Regular Visitor

When I faced this issue a couple of years ago, I found that PowerBI is unable to run stored procedures at all. This is why I use workaround: PowerApps with the only button to run the procedure.

Community Support

Hi @bisiva369

 

Please connect to the same SQL Server instance without any T-SQL query or stored procedure written, then specify a valid credential, check if the same issue occurs. 

 

If there is a SQL Server Management Studio tool on the same machine, please try with the same connection string to see if it's able to connect to this instance successfully. 

 

Best Regards,
Qiuyun Yu 

Regular Visitor

Hi Qiuyun Yu,

 

thanks for reply. I'm able to connect without stored procedure or Query. I'm able to get list of tables. but if I pass Query, I'm unable to connect.

 

Regards,

bisiva369

Regular Visitor

thanks Alexi !! PowerApps works...

 

 

 

 

 

 

Regards,

bisiva369