cancel
Showing results for 
Search instead for 
Did you mean: 

Power BI SharePoint refresh error

Hi everyone,

 

I am running a Power BI report with a dataset that's being refreshed based on some SharePoint Online libraries (lists / folders).

Now and then, my refresh fails and gives me the following error. See below.

 

Anyone who has experienced this before and has any idea on what to do about it?

Retrying the refresh action seems to work though. But it's still annoying.

 Capture.PNG

 

 

Status: Needs Info
Comments
Moderator

Hi @m2dekker,

 

From your description, the report gets data from SharePoint online libraries (lists / folders), after publish to Power BI service, the issue occurs when refreshing data, right? 

 

Would you please refresh the same report in Power BI desktop at the same time to see if the same issue occurs? 

 

When the error occurs on Power BI service, there should be a error message with RequestID and ClusterURI, would you please share these information. 

 

Best Regards,
Qiuyun Yu 

Established Member
Status changed to: Needs Info
 
Visitor

Hi @Vicky_Song

 

For sure. The error message including the info mentioned is as following:

 

 

Message: SharePoint: Request failed: The remote server returned an error: (500) Internal Server Error. (There was no endpoint listening at http://usr17718-120:32843/a626b01a61564e53975f54f21ea4015b/MetadataWebService.svc that could accept the message. This is often caused by an incorrect address or SOAP action. See InnerException, if present, for more details.) Table: ExtensionType.
Cluster URI: WABI-NORTH-EUROPE-redirect.analysis.windows.net
Activity ID: bd21fa74-595e-42bf-8fb7-ff7ac9337c6d
Request ID: 927eabd8-fd34-497e-a439-b1f9401d6762
Time: 2018-04-16 18:37:44Z

 

Refreshing the report at the same time would be almost impossible since it's scheduled in the middle of the night. I have to check with the business if they can help me out with this since it's 100% business managed.

 

It's very random but I also noticed timeouts without any further error message.

My guts tell me that this could most likely be a SharePoint related issue.

 

 

 

 

Idea Statuses