cancel
Showing results for 
Search instead for 
Did you mean: 

Power BI Service issue in Internet Explorer

I'm currently having issues viewing a report in Internet Explorer. The report works fine in Chrome, but when using Internet Explorer 11 (version 11.0.9600.18697CO) the filters won't work and data won't display. This has always worked for me previously in IE11 but seems to have been since I last downloaded the latest Power BI updates that I've been having problems. I can see that issues with IE11 have previously been reported - were these ever resolved? Thanks.

Status: Accepted
Comments
Super Contributor

@Helene

 

Which filter are you using, the built-in slicer or custom visual? Does this issue happen to all of your reports?

If issue persists, could you please provide a screenshot for it?

 

Best Regards,
Herbert

Established Member
Status changed to: Needs Info
 
Frequent Visitor

I'm using the Smart filter, which was working fine up until recently. The strange thing is that others who have a different version of IE11 (11.0.9600.18618) to mine can see this fine.

 

What I have also realised is that I can view other people's reports on my IE and they work fine (though they don't contain Smart filters). So this appears to be only the reports I have created that won't work for me. Hence I wondered if it was related to recent updates/smart filter.

 

The link below shows the report. If I try to select something in the filter menu in IE it won't work. However, it works fine in Chrome.

 

Power BI report example

Super Contributor

@Helene

 

There is a known issue related to the Smart Filter by OkViz, and Viz developer (External) is working on fix but with no ETA.

 

Best Regards,
Herbert

Established Member
Status changed to: Accepted