Power BI Service is Very Slow

Status: Needs Info
by DavidKett Frequent Visitor on ‎12-13-2018 09:58 AM

Hello, 

 

I have been using Power BI Desktop and the Service for the last 3 years everyday and over the past week I have noticed that the Power BI Service is much slower than it has ever been. It can take 5-10 seconds per click in our environment in West US and in our customer environment. 

 

I noticed the most lag when I enter edit mode and try to change up reports. When I try to drag a new field on to the canvas from the data fields pane, you use to be able to see the field name next to the mouse cursor as you dragged around the canvas however now it seems glitchy and can take up to 5 seconds to appear. 

 

We did a webinar last week and have all of this abnormal latency recorded. We do not use Power BI Premium. 

 

Has anyone else seen anything similar? Please help us get back to user experience that we are used to!

 

Thanks, 

 

David

Status: Needs Info
Comments
by kwyoung001 Visitor
on ‎12-13-2018 11:16 AM

David,

 

We are having issues too.  See my post from a few hours ago.

 

https://community.powerbi.com/t5/Issues/Power-BI-Pro-Web-is-extremely-slow/idi-p/585164

 

Kevin

by Moderator v-yuezhe-msft
on ‎12-13-2018 11:49 PM

@DavidKett,

 What web browser do you use? Please try different web browsers and check if same issue occurs.

Regards,
Lydia

by Moderator v-yuezhe-msft
on ‎12-13-2018 11:49 PM
Status changed to: Needs Info
 
by kcantor Super Contributor
on ‎12-14-2018 01:07 PM

I am having issues as well. Reports that have always been reliable are now spinning without loading the data. The refreshes occured as they should but all users are experiencing slow downs. I, personally, use Chrome. I also have users with Edge, and Mozilla experiencing issues as well.

by kwyoung001 Visitor
on ‎12-17-2018 05:06 AM

@kcantor Have you opened a ticket with MS, if so, what have they said?  It seem folks are having issues, but MS is not digging into the issue.

 

In my ticket with MS I provided traces via Fiddler and within those traces there are 404 Errors.

 

Screen Shot 2018-12-14 at 8.46.37 AM.png

 

by DavidKett Frequent Visitor
on ‎12-17-2018 09:29 AM

I have tested this in the latest versions of Edge, Chrome, and Firefox. I have confirmed these slowdowns across different users of the same tenant, accessing the PBI service from different PCs and VMs, and I have also logged in to other customer's tenants in different regions and witnessed the same issues. I think that is fair to say it is server-side issues with the Power BI Service which is unfortunante since my day to day operations depend on this SaaS. 

by DavidKett Frequent Visitor
on ‎12-18-2018 03:38 PM

I have also validated that the same slowness during Edit occurs in Power BI Premium workspaces as well as Power BI Pro workspaces. 

by Moderator v-yuezhe-msft
‎12-19-2018 12:31 AM - edited ‎12-19-2018 12:34 AM

@kwyoung001 @DavidKett,

I am unable to reproduce this issue on my side, I would recommend you open a support ticket in Power BI support site.


Regards,
Lydia

by kwyoung001 Visitor
on ‎12-19-2018 04:03 AM

@v-yuezhe-msft  Thanks.  I have a few weeks ago and I'm getting no where with support, this is why I turne to the blog.  It's very frustrating.  Is there a way to escalate tickets if we feel it's moving slow?