cancel
Showing results for 
Search instead for 
Did you mean: 

Power BI Service - Unable to render paginated report

Recently, an existing paginated report has not been able to run on our Power BI service/login. This was only detected this week, commencing 2 August 2021 - prior to this, we've not experienced this issue and have made no changes to the report. The report runs locally on my own computer (through Report Builder) without an issue. Additional testing and research shows that having the parameters in the report set to either "Internal" or "Hidden" is the cause of this - by switching to "Visible" and re-uploading to the Power BI portal, the report then loads without any error. However, we need the parameters to not be visible to the end-users - please can this issue be looked into as it appears to only be happening on the portal/PBI service.

 

Error as follows:

 

Annotation 2021-08-04 131438.png

 

 

 

 

 

 

 

 

 

 

 

 

Thanks!

Status: New
Comments
v-yingjl
Community Support

Hi @Tucksington ,

Could not reproduce it in my side as far as my test whether the properties of parameter is visiable, hidden or internal, the pagianted report works fine in Power BI Service. Testing Report Server version: 15.6.1628.2

 

You may run it in the report builder first when making the parameter hidden or internal to check whether it works. If it works in the Report Builder, try to publish to different workspaces to check; if not works, check the error message.

 

Best Regards,
Community Support Team _ Yingjie Li

Tucksington
New Member

@v-yingjl 

Thanks for your feedback. I've tested with various combinations of parameter visibility, in report builder and it works fine. Only on our Power BI portal/service does the error, as per the screenshot, appear. I have also tried publishing in different workspaces, new reports, etc etc and its the same problem. It feels like there's a bug on our Power BI service. Do you know if there's a way to get a more useful error than just "Unable to render paginated report"?

rbrocks
Frequent Visitor

I am having a similar issue. Yesterday a paginated report I ran worked fine. The formatting with fixed headers works right when I run in Report Builder. It aso worked on the service yesterday. Today, my user indicated the report would not render. I republished and now the report is rendering but the formatting is wrong and does not look how it looks when I run it in report builder. It looks right in report builder. Did something change in the service since yesterday?

v-yingjl
Community Support

@Tucksington @rbrocks ,

Currently it has been confirmed an known issue internal(Bug ID: 641226). Would update here as soon as possible if there is any progress about it.

 

Best Regards,
Community Support Team _ Yingjie Li