cancel
Showing results for 
Search instead for 
Did you mean: 

Power BI Report Will Not Work in the Published App

I have a Pro user who has published a report to a new workspace in our P2 premium capacity. Both her and I can open the report and view it fine in the workspace. We are both admins on the workspace and we are both Pro license users. 

 

When she checks the box next to the report to include in the app and then updates the app, the report does appear in the app but when we select it we get this error. "Sorry, we couldn't find that report. It may have been deleted or you may not have access to view it."

rbrocks_0-1619106474619.png

 

We have the exact same setup in a Test workspace and the report is working fine. She even published it to a whole new workspace today, and it worked there as well.  Any ideas what could be wrong here? I tried removing the content from the app, then deleting the content from the workspace, republishing and re-updating the app and that did not work. I also tried different browsers and my mobile app. I am hoping to avoid unpublishing the whole app. 

 

Status: New
Comments
v-lili6-msft
Community Support

hi

I meet a similar post, and there is a workaround as below:

 

I was able to solve by saving the same report with a different name and subsequently publishing. 

 

Regards,

Lin

rbrocks
Regular Visitor

Thanks for the suggestion @v-lili6-msft. Unfortunately we tried this and it did not work for us. I have opened a Microsoft support ticket. 

Nikoko
Regular Visitor

I have the exact problem these days. Please advise if there is any solution to it.