cancel
Showing results for 
Search instead for 
Did you mean: 

Power BI Refresh Failing

Dataset refreshes keep failing. Power BI is connected to Dynamics 365 through an API. It was working before but starting on Saturday December 7th, 2019 the refreshes kept failing and this error appeared. Can't seem to figure out how to fix it.

 

OData: The feed's metadata document appears to be invalid. Error: A supported MIME type could not be found that matches the content type of the response. None of the supported type(s) 'application/xml' matches the content type 'application/json; odata.metadata=minimal'

Status: New
Comments
Visitor

Exact same issue when trying to refresh the dataset on PowerBI online and PowerBI desktop.

Visitor

Desde chile con el mismo error de actualización desde el 7 de diciembre 

Frequent Visitor

Exact same issue, Dynamics 365 connected via API. Same error message and issue began the same time. Wondering if something was changed/updated. 

Moderator

Hi all, 

 

How did you get data from the Dynamics 365? 

I tested with Dynamics 365 follow this document, it's able to refresh data both in Power BI desktop and service. Below is my Power Query: 

 

let
    Source = OData.Feed("https://<OrgName>.api.crm5.dynamics.com/api/data/v9.1/", null, [Implementation="2.0"]),
    accounts_table = Source{[Name="accounts",Signature="table"]}[Data]
in
    accounts_table

 

Best Regards,
Qiuyun Yu 

Visitor

I've connected Power BI with Dynamics using the Dynamics Web API and by using an organizational login.

 

I've tried connecting again using the instructions in the document but it keeps giving me this error below.

 

Details: "OData: The feed's metadata document appears to be invalid. Error: A supported MIME type could not be found that matches the content type of the response. None of the supported type(s) 'application/xml' matches the content type 'application/json; odata.metadata=minimal'."

Frequent Visitor

Looks like *something* changed. I had the same issue.

 

Existing reports conected using:

 

https://[orgname].api.crm3.dynamics.com/api/data/v8.0/

 

And began failing with:

 

DataSource.Error: OData: The feed's metadata document appears to be invalid. Error: A supported MIME type could not be found that matches the content type of the response. None of the supported type(s) 'application/xml' matches the content type 'application/json; odata.metadata=minimal'.

 

Simply changing the Web Instance URL to the new one (obtained from Dynamics -> Settings -> Customizations -> Developer Resources):

 

https://[orgname].api.crm3.dynamics.com/api/data/v9.1/

 

Did not work as it did not add the 

, null, [Implementation="2.0"]

as seen in Qiuyun Yu's reply.

 

Adding that to my Source lines sort of works. As in it will refresh the data once, then complain on the next refresh, then refresh again and complain about a different table, but generally with the same complaint:

DataSource.Error: OData: The feed's metadata document appears to be invalid. Error: A supported MIME type could not be found that matches the content type of the response. None of the supported type(s) 'application/xml' matches the content type 'application/json; odata.metadata=minimal'.
Details:
DataSourceKind=OData
DataSourcePath=https://[orgname].api.crm3.dynamics.com/api/data/v9.1/$metadata

 

Dion

Visitor

I have the same issue since Saturday. D365 endpoint 9.1 was working fine and now the refresh fails in both desktop and service. 

Frequent Visitor

I have opened a support ticket. We'll see how it goes.

 

I also tried using endpoint 9.0 (as a similar issue happened back when we went from 8.0 to 8.1 or 9.0 a couple of years ago, and the solution then was to just use the old 8.0 endpoint), but that doesn't seem to help. (and my current reports still use the 8.0 endpoint and have started failing, which is what led me here.)

 

Dion

Visitor

I just checked the PowerBI again and the refreshes have started to work again all of a sudden.

 

I haven't changed anything. Must have been something internally.

Visitor

I can confirm with @MKang  that the refresh is now working. Thanks PBI team!