cancel
Showing results for 
Search instead for 
Did you mean: 

(Power BI RS - OnPrem) Custom Visual will corrupt something if guid changed and visual reimported

Dear Community,

I'm pretty new to Power BI and Custom Visuals.

I'm using API v 1.10 and Report Server on prem (March 2018).

Steps to replicate the bug:

1. create custom visual

2. import custom visual in Power BI Desktop for RS

3. include visual in report page

4. deploy report on report server

5. verify custom visual working fine

6. change visual guid

7. import visual in PBI Desktop again

8. use newly imported visual in report page

9. deploy report on report server

10. verify custom visual doesn't show up (javascript never executed. The rest of the report page is fine)

11. try to delete and reimport visual with old guid / with new guid or anything else

12 deploy on report server

13 verify custom visual still not working

14 import any other custom visual

15 deploy on report server

16 verifiy even other untouched custom visuals don't show up.

 

After deleting custom visual with new guid, when reimporting will show the 'update visual' popup..

 

Can you please try to replicate / help ?

Is any way to bring pbix file back to a 'stable' version?

Thanks.

Status: Needs Info
Comments
v-qiuyu-msft
Community Support

Hi @RBugs,

 

Would you please share .pbiviz file of your custom visual with us? You can upload it to your OneDrive and share the link here. 

 

Best Regards,
Qiuyun Yu 

v-qiuyu-msft
Community Support
Status changed to: Needs Info
 
RBugs
Frequent Visitor

Dear @v-qiuyu-msft,

thanks for your answer.

Unfortunately pbix where I encountered the issue contains customer data that can't be shared.

I can see if I can replicate in a report with other data.

Cheers,

RBugs

 

v-qiuyu-msft
Community Support

Hi @RBugs,

 

Have you reproduced the issue with other data? You can share custom visual .pbiviz file with us, then we can try to check if the issue can be reproduced on ours side. 

 

Best Regards,
Qiuyun Yu