cancel
Showing results for 
Search instead for 
Did you mean: 

Power BI Paginated Report User!UserID not same for parameters and body when embedding

When embedding a Power BI Paginated report as App Owns Data (ISV) the built-in field User!UserID, which holds the username property of the identity element, is different when used in report paramenters compared to when it is used in the body.

 

Apparently the User!UserID when executed in the context of the paramenters pane holds the GUID of the SPN (App ID) and not the username property which is expected.

 

See an example here of a simple Paginated report where the body has a text box with the value set as an expression User!UserID. Same expression is used for the default value of the report paramenter but instead of holding 'DNK', which is the value of the username property in the identity element of the embed token, the default value of the parameter is set to the App ID (Guid of the app registration). 

 

This cannot be right. It should support limiting available parameter values based on a dataset. But this is not possible as the User!UserID is always equal to the App ID when parsed from the parameter pane.

 

@AlonBAR and @chrisfin is this due to the fact that we are in preview, can this be accomplished through a workaround or will this be fixed in a future release?

 

 

 

 

Status: New
Comments
Community Support

@gronnerup 

 

To get faster and better technical support for this issue, you may directly create a support ticket.

Regular Visitor

@v-chuncz-msft Already done yesterday just after creating the issue here. 

Frequent Visitor

@gronnerup did you get any information about this issue from Microsoft support?

 

I reached out to partner support because it is an urgent issue for one of our project.

 

It's required in order to implement data security (same report, different data depending on the user specified in REST API embedding call) ... It's useless otherwise ...

Thanks for any information you can provide!

 

Frederick

Regular Visitor

@samsonfr 

I am still in contact with the Power BI Support Team.

They have reproduced the issue and I am currently waiting for feedback on some additional questions. 

 

I have tried reaching out again to see if it speeds up the process. I will keep you posted

Resolver II

Were you able to get this question answered? We're facing a similar issue.

Frequent Visitor

ETA was that a fix was to be available end of March 2020. I didn't receive any news after that.

Out of curiosity, I tried again last week and it worked for me!

Did you try recently?

Our Power BI tenant is located in North Central US (Illinois), so it it doesn't work for you maybe it's just not deployed on your tenant yet.

Frederick

Helper II

Hello,

 

I'm facing the same issue and for me it is US GCC cloud. Anybody knows whether this fix was released for US GCC cloud? 

 

Thank you,