cancel
Showing results for 
Search instead for 
Did you mean: 

Power BI Paginated Report - Default hidden parameters are not working properly

Hi,

we found a issue during last days (we think has been released an update in Power BI Services ).

Now, some hidden/multivalues parameters are not selected correclty by default when the report is opened the frist time. The report is selected only by one value, but it should be selected by multivalues coming from the previous parameters. 

it happens with following conditions:

  • only if the report is published on power bi services (in local we have not issues)
  • only if the parameter allow multiselection
  • only if the parameter is hidden
  • only if there is at least one another parameter visible before it   

Please, give us some feedback because  this is an issue that impact the usability of our released report

 

Thank you,

Andrea

Status: Investigating

Could not reproduce it in my side as far as my test.

I have set two parameters, one to allow multiple selection and hidden, another to allow multiple selection and visible.

vyingjl_0-1640067658937.png

vyingjl_1-1640067672634.png

Test in local report builder:

vyingjl_2-1640067717406.png

Test in Power BI Service:

vyingjl_3-1640067739573.png

The default value for parameter1 is set manually:

vyingjl_4-1640067767243.png

 

Whether there are any wrong steps to reproduce it or you can consider sharing more details about this issue, like 'some hidden/multivalues parameters are not selected correclty by default when the report is opened the frist time. The report is selected only by one value, but it should be selected by multivalues coming from the previous parameters. '

 

In addition, you can add some screenshots to compare in this issue which could help better.

 

Best Regards,
Community Support Team _ Yingjie Li

Comments
v-yingjl
Community Support
Status changed to: Investigating

Could not reproduce it in my side as far as my test.

I have set two parameters, one to allow multiple selection and hidden, another to allow multiple selection and visible.

vyingjl_0-1640067658937.png

vyingjl_1-1640067672634.png

Test in local report builder:

vyingjl_2-1640067717406.png

Test in Power BI Service:

vyingjl_3-1640067739573.png

The default value for parameter1 is set manually:

vyingjl_4-1640067767243.png

 

Whether there are any wrong steps to reproduce it or you can consider sharing more details about this issue, like 'some hidden/multivalues parameters are not selected correclty by default when the report is opened the frist time. The report is selected only by one value, but it should be selected by multivalues coming from the previous parameters. '

 

In addition, you can add some screenshots to compare in this issue which could help better.

 

Best Regards,
Community Support Team _ Yingjie Li

andrewbiolotb
New Member

Hi,

First of all thanks  for the answer.

 

Ok I try to explain the issue with an example:

Below you can find the list of the parameters. TimeDays, a hidden parameter which is placed after anothers visible parameters is not working properly.

Time DaysTime DaysIndeed, Subsidiary and Line parameters can filter correctly the datasets.

 

As you can see in the below screenshot, If I run the report in Local, the chart and the printed parameter (TimeDays) is working fine showing all the days.

 

LocalLocal

 

 If I run the same report on the service, the parameter selects only one value!

 

ServiceService

If I change the visibilty of TimeDays filter to Visible the report on Service works fine and all the days are selected by default

Service not hidden.PNG

 

Another test:

If I remove the dipendencies of other parameters and I move the "TimeDays" parameter in the first row, without any other parameter visibile before it, the parameter works, selecting all the days:

change order hidden.PNG

change order hidden report.PNG

 

I my opinion , all the hidden parameters with multivalues selection by default are selected only by one value if there are visible parameters before them.

 

I would like to highlight that this behavior happens only at the first access: if I try to change the selection of  the previous parameters (i.e. Period Parameter), the TimeDays is refreshed and correctly selected (even if it is hidden).

 

The last thing that I did not mention in the previous comment:

hidden parameters are using a specific dataset to have values (Available values and Default values) and the main data set are using the RSCustomDaxFilter function to filter the Timedays parameter in multivalues.

 

Thank you,

Andrea

 

 

 

DeanAdam
New Member

I have the same issue and I have created an example report to help you in reproducing the problem. One extra thing that seems to be part of the issue is a computed field in the dataset used for available values. In my example report, if I changed to using a field from the query, the problem stopped. We have a lot of MDX reports where the computed field ParameterCaptionIndented is commonly used for this.

 

Here is the example report. It is self-contained. The only data source it uses is an "Enter Data" data source.

 

<?xml version="1.0" encoding="utf-8"?>
<Report xmlns="http://schemas.microsoft.com/sqlserver/reporting/2016/01/reportdefinition" xmlns:rd="http://schemas.microsoft.com/SQLServer/reporting/reportdesigner" xmlns:cl="http://schemas.microsoft.com/sqlserver/reporting/2010/01/componentdefinition">
  <rd:ReportUnitType>Inch</rd:ReportUnitType>
  <rd:ReportID>1720c88f-00c7-4af2-96ea-1aa7dda13847</rd:ReportID>
  <AutoRefresh>0</AutoRefresh>
  <DataSources>
    <DataSource Name="EnterDataDS">
      <rd:SecurityType>Integrated</rd:SecurityType>
      <ConnectionProperties>
        <DataProvider>ENTERDATA</DataProvider>
        <ConnectString />
        <IntegratedSecurity>true</IntegratedSecurity>
      </ConnectionProperties>
      <rd:DataSourceID>3537d331-50df-4b13-b354-ceabea223d8b</rd:DataSourceID>
    </DataSource>
  </DataSources>
  <DataSets>
    <DataSet Name="EnterData">
      <Query>
        <DataSourceName>EnterDataDS</DataSourceName>
        <QueryParameters>
          <QueryParameter Name="NotUsed">
            <rd:UserDefined>true</rd:UserDefined>
            <Value>=Parameters!P1.Value</Value>
          </QueryParameter>
        </QueryParameters>
        <rd:DesignerState>
          <DataGrid xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns="">
            <RowNumber>3</RowNumber>
            <ColumnNumber>1</ColumnNumber>
            <ColumnName ColumnIndex="0" ColumnWidth="100" DataType="String">Col1</ColumnName>
            <Data ColumnIndex="0" RowIndex="0">1</Data>
            <Data ColumnIndex="0" RowIndex="1">2</Data>
            <Data ColumnIndex="0" RowIndex="2">3</Data>
          </DataGrid>
        </rd:DesignerState>
        <CommandText>&lt;Query&gt;
  &lt;XmlData&gt;
    &lt;Data&gt;
      &lt;Row&gt;
        &lt;Col1&gt;1&lt;/Col1&gt;
      &lt;/Row&gt;
      &lt;Row&gt;
        &lt;Col1&gt;2&lt;/Col1&gt;
      &lt;/Row&gt;
      &lt;Row&gt;
        &lt;Col1&gt;3&lt;/Col1&gt;
      &lt;/Row&gt;
    &lt;/Data&gt;
  &lt;/XmlData&gt;
  &lt;ElementPath&gt;Data{}/Row{Col1(String)}&lt;/ElementPath&gt;
&lt;/Query&gt;</CommandText>
      </Query>
      <Fields>
        <Field Name="Col1">
          <rd:TypeName>System.String</rd:TypeName>
          <DataField>Col1</DataField>
        </Field>
        <Field Name="Col2">
          <Value>=Fields!Col1.Value</Value>
        </Field>
      </Fields>
    </DataSet>
  </DataSets>
  <ReportSections>
    <ReportSection>
      <Body>
        <Height>0.01042in</Height>
        <Style />
      </Body>
      <Width>7.64999in</Width>
      <Page>
        <PageHeader>
          <Height>1.00931in</Height>
          <PrintOnFirstPage>true</PrintOnFirstPage>
          <PrintOnLastPage>true</PrintOnLastPage>
          <ReportItems>
            <Textbox Name="textbox103">
              <KeepTogether>true</KeepTogether>
              <Paragraphs>
                <Paragraph>
                  <TextRuns>
                    <TextRun>
                      <Value>=Globals!ReportName</Value>
                      <Style>
                        <FontFamily>Tahoma</FontFamily>
                        <FontSize>20pt</FontSize>
                        <FontWeight>Bold</FontWeight>
                        <Color>SteelBlue</Color>
                      </Style>
                    </TextRun>
                  </TextRuns>
                  <Style />
                </Paragraph>
              </Paragraphs>
              <Top>0.01389in</Top>
              <Height>0.36in</Height>
              <Width>7.64999in</Width>
              <Style />
            </Textbox>
            <Textbox Name="ParameterFooter">
              <KeepTogether>true</KeepTogether>
              <Paragraphs>
                <Paragraph>
                  <TextRuns>
                    <TextRun>
                      <Value>="Parameter  should default to: 1,2,3" + vbcrlf + "Parameter  did default to   : "  + Join(Parameters!Test1.Label, ",")</Value>
                      <Style>
                        <FontFamily>Courier New</FontFamily>
                      </Style>
                    </TextRun>
                  </TextRuns>
                  <Style />
                </Paragraph>
              </Paragraphs>
              <Top>0.37389in</Top>
              <Height>0.63542in</Height>
              <Width>7.64999in</Width>
              <ZIndex>1</ZIndex>
              <Style>
                <PaddingLeft>2pt</PaddingLeft>
                <PaddingRight>2pt</PaddingRight>
                <PaddingTop>2pt</PaddingTop>
                <PaddingBottom>2pt</PaddingBottom>
              </Style>
            </Textbox>
          </ReportItems>
          <Style />
        </PageHeader>
        <PageHeight>8.5in</PageHeight>
        <PageWidth>14in</PageWidth>
        <InteractiveHeight>811in</InteractiveHeight>
        <InteractiveWidth>8.5in</InteractiveWidth>
        <LeftMargin>1in</LeftMargin>
        <RightMargin>1in</RightMargin>
        <TopMargin>1in</TopMargin>
        <BottomMargin>1in</BottomMargin>
        <Style />
      </Page>
    </ReportSection>
  </ReportSections>
  <ReportParameters>
    <ReportParameter Name="P1">
      <DataType>String</DataType>
      <DefaultValue>
        <Values>
          <Value>1</Value>
        </Values>
      </DefaultValue>
      <Prompt>P1</Prompt>
      <Hidden>true</Hidden>
      <ValidValues>
        <ParameterValues>
          <ParameterValue>
            <Value>1</Value>
            <Label>1</Label>
          </ParameterValue>
        </ParameterValues>
      </ValidValues>
      <cl:ComponentMetadata>
        <cl:HideUpdateNotifications>true</cl:HideUpdateNotifications>
      </cl:ComponentMetadata>
    </ReportParameter>
    <ReportParameter Name="P2">
      <DataType>String</DataType>
      <DefaultValue>
        <DataSetReference>
          <DataSetName>EnterData</DataSetName>
          <ValueField>Col1</ValueField>
        </DataSetReference>
      </DefaultValue>
      <Prompt>P2</Prompt>
      <Hidden>true</Hidden>
      <ValidValues>
        <DataSetReference>
          <DataSetName>EnterData</DataSetName>
          <ValueField>Col1</ValueField>
          <LabelField>Col1</LabelField>
        </DataSetReference>
      </ValidValues>
      <MultiValue>true</MultiValue>
      <cl:ComponentMetadata>
        <cl:HideUpdateNotifications>true</cl:HideUpdateNotifications>
      </cl:ComponentMetadata>
    </ReportParameter>
    <ReportParameter Name="P3">
      <DataType>String</DataType>
      <DefaultValue>
        <DataSetReference>
          <DataSetName>EnterData</DataSetName>
          <ValueField>Col1</ValueField>
        </DataSetReference>
      </DefaultValue>
      <Prompt>P3</Prompt>
      <ValidValues>
        <DataSetReference>
          <DataSetName>EnterData</DataSetName>
          <ValueField>Col1</ValueField>
          <LabelField>Col2</LabelField>
        </DataSetReference>
      </ValidValues>
      <MultiValue>true</MultiValue>
      <cl:ComponentMetadata>
        <cl:HideUpdateNotifications>true</cl:HideUpdateNotifications>
      </cl:ComponentMetadata>
    </ReportParameter>
    <ReportParameter Name="Test1">
      <DataType>String</DataType>
      <DefaultValue>
        <DataSetReference>
          <DataSetName>EnterData</DataSetName>
          <ValueField>Col1</ValueField>
        </DataSetReference>
      </DefaultValue>
      <Prompt>Test1</Prompt>
      <Hidden>true</Hidden>
      <ValidValues>
        <DataSetReference>
          <DataSetName>EnterData</DataSetName>
          <ValueField>Col1</ValueField>
          <LabelField>Col1</LabelField>
        </DataSetReference>
      </ValidValues>
      <MultiValue>true</MultiValue>
      <cl:ComponentMetadata>
        <cl:HideUpdateNotifications>true</cl:HideUpdateNotifications>
      </cl:ComponentMetadata>
    </ReportParameter>
  </ReportParameters>
  <ReportParametersLayout>
    <GridLayoutDefinition>
      <NumberOfColumns>1</NumberOfColumns>
      <NumberOfRows>4</NumberOfRows>
      <CellDefinitions>
        <CellDefinition>
          <ColumnIndex>0</ColumnIndex>
          <RowIndex>0</RowIndex>
          <ParameterName>P1</ParameterName>
        </CellDefinition>
        <CellDefinition>
          <ColumnIndex>0</ColumnIndex>
          <RowIndex>1</RowIndex>
          <ParameterName>P2</ParameterName>
        </CellDefinition>
        <CellDefinition>
          <ColumnIndex>0</ColumnIndex>
          <RowIndex>2</RowIndex>
          <ParameterName>P3</ParameterName>
        </CellDefinition>
        <CellDefinition>
          <ColumnIndex>0</ColumnIndex>
          <RowIndex>3</RowIndex>
          <ParameterName>Test1</ParameterName>
        </CellDefinition>
      </CellDefinitions>
    </GridLayoutDefinition>
  </ReportParametersLayout>
  <Language>en-US</Language>
  <ConsumeContainerWhitespace>true</ConsumeContainerWhitespace>
</Report>

 

DeanAdam
New Member

I believe this issue has been resolved; my example above now works correctly. Can anyone confirm?