cancel
Showing results for 
Search instead for 
Did you mean: 

Power BI Goals not saving filters and page link

Morning I have a problem with power bi goals.  This week when I have been linking a goal to a report - when I save the data is brought into the goal but when I click to goto the report - the link takes me to the report but filters and page are not filtered, if I try with goals that were created last week the link takes me to the correct report page and the correct report filters are applied. 

Status: Investigating

It seems like works fine in Power BI Service currently, whether it could be a temporary issue that you can check it in other time range.

 

In addition, have you set the goal data by 'Connect to data' in Goals or the report itself has filters already? And did this issue happen in all workspce report or just in the specific report? You can try to connect to other workspace report to create a goal to check, if it happens only in the specific report, what is the data source of it, the connection mode etc.

 

Best Regards,
Community Support Team _ Yingjie Li

Comments
v-yingjl
Community Support
Status changed to: Investigating

It seems like works fine in Power BI Service currently, whether it could be a temporary issue that you can check it in other time range.

 

In addition, have you set the goal data by 'Connect to data' in Goals or the report itself has filters already? And did this issue happen in all workspce report or just in the specific report? You can try to connect to other workspace report to create a goal to check, if it happens only in the specific report, what is the data source of it, the connection mode etc.

 

Best Regards,
Community Support Team _ Yingjie Li

IGray
Frequent Visitor

Morning the goal is set by 'Connect to Data' the report uses fixed filters as well as one's set when linking data - we have  goals per service per product probably over 100 each with a different filters to the same report.  I have tested this with a new scorecard and report with the same result.  I think I have today found the issue it seems that when a goal is linked to a report, a shared view is created and I have maxed out the number of views, because if i manually delete some shared views, when I link a goal to a report and click to see the report the value is linked to, the report opens with the correct page and filters that I connected the goal to.  

CaseyRSmith
Regular Visitor

I am having the same issue. For existing scorecard goals already linked, they are opening on the correct report page with the linked value, but for any new goals added, even if I replicate the exact same goal, they open on the default report page without any filters applied. If I start an entirely new Goals Scorecard and add a goal, I see the same behavior.

 

I am not sure what the shared view limitation noted by previous commenter is regarding, but that may be what I am up against as well.