cancel
Showing results for 
Search instead for 
Did you mean: 

Power BI April update Options->Settings results in Unexpected error

 

Unexpected error.PNG

I have installed new update (tried twice) and want to enable preview features, but once I click on Optionsand settings->Options I get an Unexpected error:

 

 

 

 

 

 

 

 

 

 

See the end of this message for details on invoking
just-in-time (JIT) debugging instead of this dialog box.

************** Exception Text **************
Microsoft.Mashup.Host.Document.JavaScriptException: String was not recognized as a valid DateTime. ---> System.FormatException: String was not recognized as a valid DateTime.
   at System.DateTime.ParseExact(String s, String format, IFormatProvider provider)
   at ReleaseInfo.GetMonthYear(CultureInfo culture)
   at Microsoft.Mashup.Client.ClientShared.SendFeedbackMail.CreateMainFrownBody(StringBuilder mailBody, String feedbackType, Boolean includeScreenshot, IList`1 parameters, String screenshotPath, IPackageInfoProvider packageInfoProvider, DateTime now, String newLine, Func`2 makeBold, Boolean htmlEncodeParameterValues, Boolean prependTwoNewLines)
   at Microsoft.Mashup.Client.ClientShared.SendFeedbackMail.CreateFrownHtmlBody(String feedbackType, Boolean includeScreenshot, IList`1 parameters, String screenshotPath, IPackageInfoProvider packageInfoProvider, DateTime now)

......

Status: Needs Info
Comments
Moderator

Hi @Domantas,

 

Minimum requirements to install the Power BI desktop is .NET 4.5. Please check what's the version of .NET Framework in your machine follow this article.

 

If the version of .NET Framework is not the matter, please try the Microsoft .NET Framework Repair Tool to repair .NET Framework.

 

If issue persists, please try to enable the desktop trace file then share the trace file with us during the time that error throws our.

 

Best Regards,
Qiuyun Yu

Established Member
Status changed to: Needs Info
 
Frequent Visitor

It seems that my NET Framework is the right version:

.NET Framework version.PNG

 

But how is that relevant? Everything was working fine with the older version of PowerBI Desktop and the issue started to appear only after the upgrade. So isn't this issue solely related with April update itself?

Visitor

I can confirm the same problem with a user at my organizaiton.

April update throws the same error when trying to access options, or even trying to access "about" info.

Visitor

Should have confirmed - our organization is also on .Net 4.5.

Frequent Visitor

Kindly try to reset your system datetime setting. it's work for me.

Moderator

@Domantas@under_scores Please enable the desktop trace file then share the trace file with us during the time that error throws out.

 

Also there is a new April desktop version 2.45.4704.722 released on 4/17/2017. Please try this version to see if the same error occurs.

 

Best Regards,
Qiuyun Yu

Visitor

Thank you @nipun_khant007, your suggestion worked! Our datetime setting for our corporate build is set to yyyy-mm-dd. I tried the reset, and can confirm when set to M/d/yyyy, Power BI options are accessible again. Soon as I try changing my time back to yyyy-mm-dd, the error occurs again.

 

Appreciate the heads up @v-qiuyu-msft about the new release. I tried installing, can confirm that I'm on 2.45.4704.722 via add/remove programs, but same error when I'm on a datetime setting of yyyy-mm-dd (which our whole company is).

 

 

Moderator

Hi @under_scores,

 

Please enable the desktop trace, then use the same steps to reproduce the issue. Share the trace file around that time the error throws out here.

 

Best Regards,
Qiuyun Yu

Frequent Visitor

Sorry, but I cannot figure out what is this trace file and how to make it. Would it be possible to get some guidance?