cancel
Showing results for 
Search instead for 
Did you mean: 

Parquet connector error after November22 Update

Hello,

Hi,

 

We have some PowerBIs that use Parquet files as a data source. Prior to the November22 update, the files were opening just fine. But after installing the update, I get the following error.

 

Unexpected error: Could not load file or assembly 'ParquetSharp, Version=0.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35' or one of its dependencies.

 

I've searched on Google and the Community here, but found nothing. What is wrong with this update? Do I need to install any extra package?

 

However, if I uninstall the November22 binaries and go back to October22, the parquet connector works again.

Status: Delivered

Thanks for Silviu_O ‘s sharing.

 

You may downloaded it once more and gave "repair" to reinstall.

 

Best regards.
Community Support Team_ Caitlyn

Comments
knkirby
Regular Visitor

Was working fine until this morning. Same error shows up "Could not load file or assembly 'ParquetSharp..."

LuukTijssen2
Frequent Visitor

Same isue over here, very annoying

Silviu_O
New Member

I also have the same error.

 

Are we waiting for the December 2022 update?

 

Update:

I downloaded it once more and gave "repair" to reinstall.
Now everything works ok when importing parquet data.

DataWhisperer
New Member

Thanks for the update @Silviu_O.

 

I had the same issue as well, with my PBIX failing to load any Parquet file sourced data (due to PBI Desktop apparently failing to load the ParquetSharp assembly properly).

 

Per your suggestion, I reran the installer, selected the "Repair" installation option, and let it run to completion.  Upon subsequently reloading the PBIX file, everything ran smoothly.

 

Problem solved.

 

 

v-caitlyn-mstf
Community Support
Status changed to: Delivered

Thanks for Silviu_O ‘s sharing.

 

You may downloaded it once more and gave "repair" to reinstall.

 

Best regards.
Community Support Team_ Caitlyn

knkirby
Regular Visitor

Great uninstall and reinstall worked for me.

ianton_ellt
Frequent Visitor

Hello again,

 

I've come back and seen the feedback from other users. I've redownloaded it again and it now works as expected.

 

Thanks

olgaia
Advocate I

We are now (since last Tuesday) experiencing the same issue in DataFlows! Please assist!