cancel
Showing results for 
Search instead for 
Did you mean: 

Parameters are not getting passed to Snowflake in Direct Query Mode

Noticed that parameters are not getting passed to Snowflake in Direct Query Mode. Looking for solutions. Even the custom connectors won't work in Direct Query Mode.

Status: New
Comments
Community Support

hi  @sapankumaarjain 

If you change the directquery mode to import mode, then see if it works well. or have a test by other datasource. Please make the Type is not Any for parameter.

 

 

Regards,

Lin

Regular Visitor

Hi @v-lili6-msft 

 

We have to use direct query mode and this is our requiremnt with Snowflake. Type is Text for parameter.

Any suggestions if you can provide on Direct Query with Snowflake as source.

 

Regards,

Sapan

Community Support

hi  @sapankumaarjain 

Use latest version or go to file-Option and setting-Preview features-enable-store datasets using enhance metadata.

then create a new sample report and test it again.

 

If it persists, you may create a support ticket for assistance.

 

Regards,

Lin

Regular Visitor

Hi @v-lili6-msft ,

 

I am using the Version: 2.85.985.0 64-bit (September 2020).

 

And the option you have mentioned is not available in settings.

 

Please advise.

 

Regards,

Sapan

Community Support

hi  @sapankumaarjain

In this version, store datasets using enhance metadata is GA, so it is not available in settings.

Parameter in directquery is supported after 2020 June, sorry i don't have Snowflake in my side, so i would suggest you create a support ticket for further help.

 

Regards,

Lin