cancel
Showing results for 
Search instead for 
Did you mean: 
0

Paginated Report Builder Dates Passing to Power BI Dataset in Incorrect Format

Hi all,

I am managing an estate of around 70+ paginated reports. All reports were working successfully up until yesterday. 

Originally noticed as reports were failing to load with the following error:

Unable to render paginated report

Query execution failed for dataset "Summary".

by cancelling the report load and changing the date to anything less than 12/12/2022 e.g. a date which can be a month or a day I noticed that it was failing due to the date being passed to the Power BI dataset in the wrong format
cjbowman69_0-1652455320253.png

Paginated report builder itself knows the format is correctly 3rd May but Power BI seems to think this is the 5 March.
Browser Date format is UK (tried in Edge and Chrome)

cjbowman69_1-1652455393044.png

In Report Builder I have specified the format for my parameter:

cjbowman69_2-1652455465686.png

and I have tried both with and without Language set in the report itself:

cjbowman69_3-1652455557432.png

As mentioned, this was working as expected until today. Some reports still work fine, others are failing. 

The date format in the Power BI dataset/model is dd/mm/yyyy too.

Please advise.
Status: Delivered

Glad to hear that this issue has been solved already and this issue would be closed.

 

Best Regards,
Community Support Team _ Yingjie Li

Comments
v-yingjl
Community Support
Status changed to: Needs Info

Could not reproduce it in my side as far as my test. When I set date parameter for a paginated report, it works fine in Power BI Service.

 

When connecting to Power BI Dataset in Report Builder, how did you set the parameter for the report and how did you set it in the query designer? Please consider sharing the reproducing steps abou this issue.

 

In addition, the version of Power BI Service and Power BI Report Builder would be helpful.

 

Best Regards,
Community Support Team _ Yingjie Li

cjbowman69
Regular Visitor

Hi Yingjie Li,

 

We have made no changes over the weekend however the issue has resolved. This leads me to believe it must have been a bug with the service which has since been resolved. 

 

Kind regards,

Christian

v-yingjl
Community Support
Status changed to: Delivered

Glad to hear that this issue has been solved already and this issue would be closed.

 

Best Regards,
Community Support Team _ Yingjie Li