cancel
Showing results for 
Search instead for 
Did you mean: 

PBI RS January 2019 - Power Query Editor "Group By" Fails on Oracle Source

Hello all,

 

with the new January 2019 release it is not possible to apply the "Group by" step to your Oracle data source anymore (see screenshots). Problem can be reproduced on different servers, databases, tables and computers.

 

This is a massive show stopper for us as we have many users using Oracle as a source in Power BI.

 

Can you please look into this issue? Thank you! :-)

 

2019-01-29_10h54_52.pngSelect Group by on a column in PQE2019-01-29_10h56_03.pngClick OK2019-01-29_10h56_17.pngAlways receive this error, tested it on different servers and databases

Status: New
Comments
Frequent Visitor

Hi ferzfeld, have you tested your query on SQL developer? The error shown is not PowerBI but Oracle and happens when an aggregate measure is used with no GROUP BY clause.

Frequent Visitor

Hi 7700,

 

Thank you for your reply.

 

  • No query is used, the following steps have been taken for this example:
    • Get Data -> Oracle Source
    • Select the Plant-Dimension table from the oracle schema
    • Edit --> Power Query Editor
    • Right click on the column, select "Group By", click OK
    • Generated SQL Statement by PQE sent to Oracle DB is faulty and causes Error
  • The exact SAME steps performed on the August 2018 PBI RS Desktop will work just fine

 

Luckily - reports that are created with the August 2018 release and published to the January 2019 Report Server will still refresh. The bug lies in Power BI Desktop January 2019. 

 

Actually we have Microsoft consultants in our enterprise at the moment and they were able to reproduce this issue as well.

 

By the way - the same steps on a Microsoft SQL Server work fine, only Oracle DB connection seems to have this problem.

 

Looking forward from a feedback from Microsoft about this :-)

Occasional Visitor

We are getting the exact the same error.  Does not  ocurr with Microsoft SQL server databases.  Just the Oracle ones.  I expect Power Query to correctly construct the query for Oracle if Power BI is to be an overall data visualization tool.   Error occurrs even when picking just one field to group and requesting a row count.  

 

Also have a Power Query built before December for an Oracle data table using a Grouped By and it stlll works.  Duplicated the table today and tried a very simple Grouped By and it now fails.