cancel
Showing results for 
Search instead for 
Did you mean: 

Oracle: ORA-12154: TNS:could not resolve the connect identifier specified

When creating a new Oracle data source, I'm receiving the following message:

 

Unable to connect: We encountered an error while trying to connect to . Details: "We could not register this data source for any gateway instances within this cluster. Please find more details below about specific errors for each gateway instance."Hide details

Activity ID:5d862ea5-3a96-0835-6db7-8f7f459bf828
Request ID:0ad21c9b-99f9-419b-2dda-37a8d184731e
Cluster URI:https://wabi-us-east2-redirect.analysis.windows.net
Status code:400
Error Code:DMTS_PublishDatasourceToClusterErrorCode
Time:Wed Sep 12 2018 09:58:40 GMT-0400 (Eastern Daylight Time)
Version:13.0.6617.130
 Cannot connect to the mashup data source. See error details for more information.
Underlying error code:-2147467259
Underlying error message:Oracle: ORA-12154: TNS:could not resolve the connect identifier specified
DM_ErrorDetailNameCode_UnderlyingHResult:-2147467259
Microsoft.Data.Mashup.ValueError.DataSourceKind:Oracle
Microsoft.Data.Mashup.ValueError.DataSourcePath: 
Microsoft.Data.Mashup.ValueError.ErrorCode:-2146232008
Microsoft.Data.Mashup.ValueError.Message:ORA-12154: TNS:could not resolve the connect identifier specified
Microsoft.Data.Mashup.ValueError.Reason:DataSource.Error

 

 

I have the following already configured:

 

1) Oracle 12.1 64-bit client is installed.

2) ORACLE_HOME and TNS_ADMIN locations are setup in PATH environment variable.

3) TNS_ADMIN evironment variable is added as an environment variable.

4) Entry in tnsnames.ora file, i.e.) net_service_name in tns entry is being used as 'Server' value for data source.

5) NAMES_DIRECTORY_PATH=(TNSNAMES, EZCONNECT) in sqlnet.ora file.

6) The value of the key "Oracle_home" in the registry under HKEY_LOCAL_MACHINE\SOFTWARE\ORACLE\KEY_OraClient12Home1 is set to the correct path.

7) The registry key for "TNS_ADMIN" is correctly set.

😎 There are not multiple Oracle homes.

 

There were already 2 Oracle data sources that previously worked.  Now, unsure why, they no longer work and the new data source creation is failing when attempted to add an Oracle database.

 

Thanks in advance for your help!

 

Frank

Status: New
Comments
v-qiuyu-msft
Community Support

Hi @anelliaf,

 

From the error message, the issue could occur when Oracle client is not configured properly. Please follow this article to troubleshoot the issue: https://docs.microsoft.com/en-us/power-bi/service-gateway-onprem-manage-oracle#troubleshooting

 

If there is a Power BI desktop installed on the same machine as on-premise data gateway installed, please connect to the same Oracle in Power BI to see if the same issue occurs. 

 

Please update the on-premise data gateway to the latest version 14.16.6808.1

 

Best Regards,
Qiuyun Yu 

anelliaf
Helper II

Hi Qiuyun,

 

I tested the connection using Power BI desktop on the gateway server and it worked.  It doesn't make sense since the data source connections use to work using the Gateway.

 

I'm still receiving the ORA- error using trying to create the data source on the Gateway.

 

Any other ideas?

 

Thanks,

Frank

onbi
Helper I

 This issue resolved? Because, we're also facing the same issue.

 

If it was resolved then, what's the solution to this problem?

justinbouchard
Frequent Visitor

I'm having the same issue. I can connect with PowerBi Desktop, but not through the gateway.