cancel
Showing results for 
Search instead for 
Did you mean: 

On-premises gateway update failed

I have been evaluating the on-premises gateway. I installed the gateway, successfully created several reports accessing Oracle databases using it, but other users could not access those reports, though I shared them. I was notified there was a new version of the gateway software, so I ran the gateway update. Its progress bar went to the end, and has stayed there for several hours with the text 'Please wait'.

I have seen the issue that suggests deinstalling the gateway and reinstalling it when there are problems. Will this remove all the gateway access set-up? Will I have to recreate all the database queries? Where can I find them in order to back them up?

Status: New
Comments
Community Support

@colin_sutton ,

 

If you still remember the recover key, you don't need to configure the data source settings again in power bi service. For more details, please refer to:

https://docs.microsoft.com/en-us/data-integration/gateway/service-gateway-recovery-key

 

Regards,

Jimmy Tao

Frequent Visitor

I installed the new gateway software 3000.40.15 on another computer and successfully migrated from the old gateway. My reports are now accessible from the Power BI desktop - but not from the Power BI web application.

Frequent Visitor

It workd from the desktop but not the web app:

 

Cannot load model

Couldn't load the model schema associated with this report. Make sure you have a connection to the server, and try again.

Please try again later or contact support. If you contact support, please provide these details.

Activity ID: 6e70b379-3b2b-42ee-b627-0efffab1b35b

Request ID: c965f75a-bb0a-2909-11cd-827f19232e23

Correlation ID: a5b51ff2-9a10-86e7-098c-a128442d4735

Time: Tue May 26 2020 12:20:29 GMT+1000 (Australian Eastern Standard Time)

Service version: 13.0.13322.215

Client version: 2005.2.01092-train

Cluster URI: https://wabi-australia-east-a-primary-redirect.analysis.windows.net/

Community Support

@colin_sutton ,

 

It's weird and I could not reproduce this issue. I would suggest you create a support ticket here for further analysis.

Support Ticket.gif 

Regards,

Jimmy Tao