cancel
Showing results for 
Search instead for 
Did you mean: 

ORA-00904: "a1": invalid identifier. The exception was raised by the IDbCommand interface.

Hi,

I created a table visualization with 6 to 7 columns, the output providing more than 1 lakh record, initially, table visualization will show some record with a scroll bar, whenever i using the scroll bar to see more record that time I got this error, kindly refer a screenshot for your reference. 

 

Issue1.1.PNG

 

Once I click the "See details" I got an error message like "ORA-00904: "a1": invalid identifier. The exception was raised by the IDbCommand interface."

Issue1.PNG

 

Note: With the same error, If I add or remove any column to the table data refreshing and coming, again if I scroll the same error I got.

 

I am using Direct Query mode, this issue is in Power BI Desktop latest version.

 

 

Status: Needs Info
Comments
Moderator

Hi @kskarthick,

 

Please add a visual level filter in the table visual to return almost one hundred records to see if the same issue occurs. 

 

Would you please change the connection mode from DirectQuery to Import to see if the same issue occurs? 

 

Best Regards,
Qiuyun Yu 

Established Member
Status changed to: Needs Info
 
Frequent Visitor

Hi,

 

We loaded less data by adding page filter, so it's coming now without error.

 

Maybe this issue due to the huge data(more than 10 Lakh records).