New modelling view diagrams corrupted in Feb 2019 PBID build

Status: Needs Info
by nariusp on ‎02-12-2019 04:06 AM

The latest Feb release of Power BI Desktop causes issues with existing diagrams in the new modelling view. 

 

1) Tables are auto-arranged where they were manually positioned before.

2) All relationship lines are missing but re-appear when you click anywhere on the diagram background.

3) When you move a table it does not always respond and you have to click on it again and move it, ususally the first table you trry to move on any diagram.

4) When you move a table the relationship lines do not move with the object and appear disconnected. You have to click on the background to get the lines to redraw to the new positions.

 

None of the above problems occured in the December build. 

 

pbiddiagrambug.JPG

Status: Needs Info
Comments
by jpayne Regular Visitor
on ‎02-13-2019 10:30 AM

I CONSTANTLY have to rearrange (manually) my tables - the app always forces back to a *star* schema... It is a huge waste of time. I have gone to the other forums and followed instrucitons to turn off all the *autodetect* settings which supposedly cause this problem - but no luck! It is terrbile.

by Moderator v-qiuyu-msft
Friday

Hi @nariusp @jpayne , 

 

Would you please record a video to show the issue? Thanks. 

 

Best Regards,
Qiuyun Yu 

by Moderator v-qiuyu-msft
Friday
Status changed to: Needs Info
 
by jpayne Regular Visitor
Tuesday - last edited Tuesday

I may have figured this out. 

 

By adding a new view/tab in the relationship view canvass, and manually adding tables, this view seems like it does not scramlbe when i add new talbes or upload / DL from pbis.

 

But the main (generic/automatic) view/tab always does.

 

I would mark this "solved", except, it is NOT. The bug persists. A work around is NOT a solution.

 

A solution is a fix to the bug, which many people besides me have brought up.

 

Nobody seems to want the main model/relationship view canvas to reset itself to a Snow-flake schema every time they add a table or upload/dl from PBIS.

 

Please fix this.

 

Thank you

Idea Statuses